Unable to install dependencies required by darlinghq

I’m trying to install the packages required to build darlinghq:
https://docs.darlinghq.org/build-instructions.html

However looks like something is broken:

# dnf install make cmake clang bison dbus-devel flex glibc-devel.i686 fuse-devel \
systemd-devel elfutils-libelf-devel cairo-devel freetype-devel.{x86_64,i686} \
libjpeg-turbo-devel.{x86_64,i686} fontconfig-devel.{x86_64,i686} libglvnd-devel.{x86_64,i686} \
mesa-libGL-devel.{x86_64,i686} mesa-libEGL-devel.{x86_64,i686} mesa-libGLU-devel.{x86_64,i686} \
libtiff-devel libxml2-devel libbsd-devel git git-lfs libXcursor-devel \
libXrandr-devel giflib-devel pulseaudio-libs-devel libxkbfile-devel \
openssl-devel llvm libcap-devel libavcodec-free-devel libavformat-free-devel
Last metadata expiration check: 2:28:05 ago on Thu 15 Feb 2024 03:16:09 AM UTC.
Package make-1:4.4.1-2.fc39.x86_64 is already installed.
Package cmake-3.27.7-1.fc39.x86_64 is already installed.
Package clang-17.0.6-2.fc39.x86_64 is already installed.
Package libglvnd-devel-1:1.7.0-1.fc39.x86_64 is already installed.
Package mesa-libGL-devel-23.3.5-1.fc39.x86_64 is already installed.
Package mesa-libEGL-devel-23.3.5-1.fc39.x86_64 is already installed.
Package mesa-libGLU-devel-9.0.3-1.fc39.x86_64 is already installed.
Package git-2.43.0-1.fc39.x86_64 is already installed.
Package libXcursor-devel-1.2.1-4.fc39.x86_64 is already installed.
Package libXrandr-devel-1.5.4-1.fc39.x86_64 is already installed.
Package llvm-17.0.6-3.fc39.x86_64 is already installed.
Error: 
 Problem 1: package libavcodec-free-devel-6.0-11.fc39.i686 from fedora requires libavcodec-free(x86-32) = 6.0-11.fc39, but none of the providers can be installed
  - conflicting requests
  - libavcodec-free-6.0-11.fc39.i686 from fedora  does not belong to a distupgrade repository
  - package libavcodec-free-devel-6.0-11.fc39.x86_64 from fedora requires libavcodec-free(x86-64) = 6.0-11.fc39, but none of the providers can be installed
  - problem with installed package ffmpeg-libs-6.0.1-3.fc39.x86_64
  - package ffmpeg-libs-6.0.1-3.fc39.x86_64 from @System conflicts with libavcodec-free provided by libavcodec-free-6.0-11.fc39.x86_64 from fedora
  - package ffmpeg-libs-6.0-16.fc39.x86_64 from rpmfusion-free conflicts with libavcodec-free provided by libavcodec-free-6.0-11.fc39.x86_64 from fedora
  - package ffmpeg-libs-6.0.1-3.fc39.x86_64 from rpmfusion-free-updates conflicts with libavcodec-free provided by libavcodec-free-6.0-11.fc39.x86_64 from fedora
  - package libavcodec-free-devel-6.0.1-2.fc39.i686 from updates requires libavcodec-free(x86-32) = 6.0.1-2.fc39, but none of the providers can be installed
  - libavcodec-free-6.0.1-2.fc39.i686 from updates  does not belong to a distupgrade repository
  - package libavcodec-free-devel-6.0.1-2.fc39.x86_64 from updates requires libavcodec-free(x86-64) = 6.0.1-2.fc39, but none of the providers can be installed
  - package ffmpeg-libs-6.0.1-3.fc39.x86_64 from @System conflicts with libavcodec-free provided by libavcodec-free-6.0.1-2.fc39.x86_64 from updates
  - package ffmpeg-libs-6.0-16.fc39.x86_64 from rpmfusion-free conflicts with libavcodec-free provided by libavcodec-free-6.0.1-2.fc39.x86_64 from updates
  - package ffmpeg-libs-6.0.1-3.fc39.x86_64 from rpmfusion-free-updates conflicts with libavcodec-free provided by libavcodec-free-6.0.1-2.fc39.x86_64 from updates
 Problem 2: package libavformat-free-devel-6.0-11.fc39.i686 from fedora requires libavformat-free(x86-32) = 6.0-11.fc39, but none of the providers can be installed
  - conflicting requests
  - libavformat-free-6.0-11.fc39.i686 from fedora  does not belong to a distupgrade repository
  - package libavformat-free-devel-6.0-11.fc39.x86_64 from fedora requires libavformat-free(x86-64) = 6.0-11.fc39, but none of the providers can be installed
  - problem with installed package libavdevice-6.0.1-3.fc39.x86_64
  - package libavdevice-6.0.1-3.fc39.x86_64 from @System requires ffmpeg-libs(x86-64) = 6.0.1-3.fc39, but none of the providers can be installed
  - package libavdevice-6.0.1-3.fc39.x86_64 from rpmfusion-free-updates requires ffmpeg-libs(x86-64) = 6.0.1-3.fc39, but none of the providers can be installed
  - package libavdevice-6.0-16.fc39.x86_64 from rpmfusion-free requires ffmpeg-libs(x86-64) = 6.0-16.fc39, but none of the providers can be installed
  - package ffmpeg-libs-6.0.1-3.fc39.x86_64 from @System conflicts with libavformat-free provided by libavformat-free-6.0-11.fc39.x86_64 from fedora
  - package ffmpeg-libs-6.0-16.fc39.x86_64 from rpmfusion-free conflicts with libavformat-free provided by libavformat-free-6.0-11.fc39.x86_64 from fedora
  - package ffmpeg-libs-6.0.1-3.fc39.x86_64 from rpmfusion-free-updates conflicts with libavformat-free provided by libavformat-free-6.0-11.fc39.x86_64 from fedora
  - package libavformat-free-devel-6.0.1-2.fc39.i686 from updates requires libavformat-free(x86-32) = 6.0.1-2.fc39, but none of the providers can be installed
  - libavformat-free-6.0.1-2.fc39.i686 from updates  does not belong to a distupgrade repository
  - package libavformat-free-devel-6.0.1-2.fc39.x86_64 from updates requires libavformat-free(x86-64) = 6.0.1-2.fc39, but none of the providers can be installed
  - package ffmpeg-libs-6.0.1-3.fc39.x86_64 from @System conflicts with libavformat-free provided by libavformat-free-6.0.1-2.fc39.x86_64 from updates
  - package ffmpeg-libs-6.0-16.fc39.x86_64 from rpmfusion-free conflicts with libavformat-free provided by libavformat-free-6.0.1-2.fc39.x86_64 from updates
  - package ffmpeg-libs-6.0.1-3.fc39.x86_64 from rpmfusion-free-updates conflicts with libavformat-free provided by libavformat-free-6.0.1-2.fc39.x86_64 from updates
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages)

Because you’re using ffmpeg-libs from RPM Fusion in place of libavcodec-free et al., you need to install ffmpeg-devel instead of libavcodec-free-devel and libavformat-free-devel.

2 Likes