Tracker3 (tracker-miner-fs-3) Constantly Running

/usr/libexec/tracker-miner-fs-3 is unendingly running and at the top of my resource (CPU) usage at every boot. I’ve tried to find what the problem is online, but the only things I see are how to disable it completely. I do not want to disable it completely. I want it to work as intended without making my laptop go brrrrrrrrrr.

Some Output Error

Again, can’t find much info online about this stuff.

tracker3 daemon -f
17 Mar 2023, 14:51:19:  ✗     RSS/ATOM Feeds          - Not running or is a disabled plugin

(tracker daemon:5283): Tracker-CRITICAL **: 14:51:44.457: Could not get miner progress for 'org.freedesktop.Tracker3.Miner.Files': Timeout was reached
Could not get status from miner: org.freedesktop.Tracker3.Miner.FilesPress Ctrl+C to stop

Hi - not an expert but one thought, have you tried resetting the tracker database? (Idea sourced from here)

tracker reset --hard
tracker daemon --start

That helped me out in a somewhat similar situation a while back.

1 Like