TLP with Scarlett 2i2 autosuspend

I have a Scarlett 2i2 which disconnects its USB after approx 8 sec. Reconnects with new recording, but the initial disconnect annoys. I’ve traced to TLP; after uninstall of tlp Scarlett remains connected. I would like to run tlp, but can live without it. I tried editing the ‘tlp.conf’ file to no affect. Anyone here know the trick to making the edits stick?


What changes have you made to tlp.conf?

Shoud be case of issueing:

sudo systemctl restart tlp

or Rebooting.

Thanks Tom.

1 Like

Oh, yes I’ve done the rebooting and restarting. Everything in the /etc/tlp.conf file is #ed. I’ve removed the # on the ‘autosuspend’ line. And I’ve tried blacklisting the Scarlett, of course, did not work. Am I missing a detail in the ‘tlp.conf’ file that needs to be made? BTW, I even did a ‘PARAM=’ entry in the /etc/tlp.d/*.config .


I suggest installing fpaste:

Then could you please issue:

cat /etc/tlp.conf |fpaste

May give use some idea whats going on.

Also whats the output of:

systemctl status tlp 

After the disconnect & reconnect

Thanks Tom.

1 Like