Thunderbird flatpak crashes

when I start Thunderbirt Flatpak it starts, runs, and crashes without a warning, without reporting an error.

I had this problem several times with different Fedora kde installations with different flatpaks, a new installation with the deletion of all data did not help, so far only a new installation of fedora has helped.

can someone help me with this

Please run it from command line and report any errors here

flatpak run org.mozilla.Thunderbird

Is the Flatpak from Fedora repos or Flathub?

What’s the output of org.mozilla.Thunderbird ?

I’m running Thunderbird from Flatpak on Fedora KDE without issue from Flathub.

the output is this:

flatpak run org.mozilla.Thunderbird

ATTENTION: default value of option mesa_glthread overridden by environment.
ATTENTION: default value of option mesa_glthread overridden by environment.
[Parent 2, Main Thread] WARNING: Running in confined mode, using Portal notifications. Some features and hints won't be supported: 'glib warning', file /builds/worker/checkouts/gecko/toolkit/xre/nsSigHandlers.cpp:167

(thunderbird:2): libnotify-WARNING **: 10:50:45.220: Running in confined mode, using Portal notifications. Some features and hints won't be supported

I’m not sure which repo it comes from, but Fedora Flatpaks is actually prioritized and I don’t know how to find it out

can anyone help me?

You can run flatpak info org.mozilla.Thunderbird. Origin will be either fedora or flathub.

If it’s fedora, you could try the flathub version:

flatpak install --reinstall flathub org.mozilla.Thunderbird

thanks a lot, it was flathub, I tried it with the Fedora repo but it didn’t help, the problem was there too.

I think those are meaningless warnings that do trigger the crash, see 1744389 - Silence "ATTENTION: default value of option mesa_glthread overridden by environment." warning when not needed

when you start the app from command line, you said it crashes, does it throw you back at the command line? Are you sure it isn’t running somewhere in the background?

You can try flatpak --reset org.mozilla.Thunderbird to remove overrides, then flatpak run org.mozilla.Thunderbird

A little flatpak-related isssue is that you don’t find logs or debugging information on your system, it’s all in the sandbox. If you want to further troubleshoot, you may want to have a look into debugging:

I come back to the comand line after the crash and it is not running in the background.
when I use
flatpak --reset org.mozilla.Thunderbird
I get this error message

Error: "org.mozilla.Thunderbird" is not a Flatpak command. Did you mean "remote-add"?

See ‘flatpak --help’

sorry, it’s flatpak override --reset org.mozilla.Thunderbird (but if you haven’t done anything manually, it won’t make a difference)

removing the Overrides doesn’t help.
When I run
flatpak run --command=sh org.mozilla.Thunderbird
it just kicked me out after a few seconds back in to the main Terminal, but after I am back in the main Terminal I can not type anything in the Terminal in it, I have restart it in order to do anything.

check your journal for flatpak related issues.

other flatpaks are running fine?

yes, other flatpaks are running perfect fine

Does clearing the mesa shader cache help?
rm -rf ~/.var/app/org.mozilla.Thunderbird/cache/mesa_shader_cache/*

sorry, this also doesn’t work. it still crashes when I start Thunderbirt after clearing the cache

i could reproduce the probelem with other flatpak applications, when i start a flatpak application i always get a notification that says:
Background activity

[Application name] is running in the background.
Learn more (button)

now when I click on “learn more” a dialog pops up which reads:

This could be for a legitimate reason, but the application has no details.

Note that forcing an application to quit can lead to data loss.

As options I can choose between “allow” and “force quit”.
if you now click on “drag” in the tie bar, the application drags itself and can no longer be started properly, see above.

Can anyone help me?

Similar topic: KDE warning if Flatpak-app goes into background mode (on LibreOffice as example) (although different app)

You can use Flatseal. For a given app, scroll all the way down to the Portals section, and enable the Background permission. GNOME also has this in its Settings, but KDE does not.

There have been some reports of the Background portal misbehaving, especially on KDE.