Description not filled in by author. Very likely personal repository for testing purpose, which you should not use.

Installation Instructions

Instructions not filled in by author. Author knows what to do. Everybody else should avoid this repo.

Active Releases

The following unofficial repositories are provided as-is by owner of this project. Contact the owner directly for bugs or issues (IE: not bugzilla).

Release Architectures Repo Download Fedora 36 x86_64 (0)* Fedora 36 (0 downloads)

* Total number of packages downloaded in the last seven days.

This is a companion discussion topic for the original entry at https://copr.fedorainfracloud.org/coprs/tavie/ros2/

I cannot use ros2 run command on fedora 38. I got the error below when i tried to run demo_nodes.

[erhangk@fedora ~]$ ros2 run demo_nodes_cpp talker
Failed to load entry point 'run': bad marshal data (unknown type code)
Traceback (most recent call last):
  File "/usr/lib64/ros2/bin/ros2", line 33, in <module>
    sys.exit(load_entry_point('ros2cli==0.18.7', 'console_scripts', 'ros2')())
  File "/usr/lib64/ros2/lib/python3.11/site-packages/ros2cli/cli.py", line 50, in main
  File "/usr/lib64/ros2/lib/python3.11/site-packages/ros2cli/command/__init__.py", line 237, in add_subparsers_on_demand
    extension = command_extensions[name]
KeyError: 'run'

Thanks for the info, i know what the issue is, i need to repackage everything to fix it. I am currently on vacation so it might be delayed until September.

okay, i fixed the issue. I also needed to restructure the packages a bit to allow for multiple ros versons. So the naming scheme from f38 onwards is ros2--.

Successfully installed ros2 on f38, thank you

How were you able to install ROS2 on fedora38? What guide did you use? Much appreciated, am a new Fedora and ROS user.

I followed the instructions from https://copr.fedorainfracloud.org/coprs/tavie/ros2/

I’m trying to launch my own package called atlas_description.

When I run ros2 launch atlas_description viewatlas.launch.py

I get the error: [ERROR] [launch]: Caught exception in launch (see debug for traceback): Caught exception when trying to load file of format [py]: No module named 'xacro'

I already have xacro installed (checked via pip).

Additionally when I try ros2 launch robots viewatlas.launch.py

I get the error: Package 'robots' not found: "package 'robots' not found, searching: ['/home/stevens/robotws/install/atlas_description', '/usr/lib64/ros2-humble']"

Any ideas as to what’s going on? I’m new to ROS2 and how COPR works, thanks.

do you have ros2-humble-xacro installed? You probably are just missing the Cmake configs i assume, those are contained in the mentioned package

Recently tried installing ROS2 and while trying to run the demos from the official website, the cpp talker works just fine, the python listener does not however.

Traceback (most recent call last):
  File "/usr/lib64/ros2-humble/lib/demo_nodes_py/listener", line 33, in <module>
    sys.exit(load_entry_point('demo-nodes-py==0.20.3', 'console_scripts', 'listener')())
  File "/usr/lib64/ros2-humble/lib/python3.11/site-packages/demo_nodes_py/topics/listener.py", line 37, in main
    node = Listener()
  File "/usr/lib64/ros2-humble/lib/python3.11/site-packages/demo_nodes_py/topics/listener.py", line 27, in __init__
  File "/usr/lib64/ros2-humble/lib/python3.11/site-packages/rclpy/node.py", line 199, in __init__
    self._parameter_event_publisher = self.create_publisher(
  File "/usr/lib64/ros2-humble/lib/python3.11/site-packages/rclpy/node.py", line 1290, in create_publisher
  File "/usr/lib64/ros2-humble/lib/python3.11/site-packages/rclpy/type_support.py", line 35, in check_is_valid_msg_type
  File "/usr/lib64/ros2-humble/lib/python3.11/site-packages/rclpy/type_support.py", line 31, in check_for_type_support
    raise NoTypeSupportImportedException()
rclpy.exceptions.NoTypeSupportImportedException: no type_support imported
[ros2run]: Process exited with failure 1

Am I missing any package? Everything (according to the official website) dependency is installed.

Sorry, i was rather busy. This looks like you are missing some message package, but I am lacking context here.
I assumed you did:

ros2 run demo_nodes_cpp talker
[INFO] [1701855557.041287331] [talker]: Publishing: 'Hello World: 1'
[INFO] [1701855558.041373355] [talker]: Publishing: 'Hello World: 2'
[INFO] [1701855559.041284097] [talker]: Publishing: 'Hello World: 3'
[INFO] [1701855560.041378988] [talker]: Publishing: 'Hello World: 4'
[INFO] [1701855561.041320246] [talker]: Publishing: 'Hello World: 5'

And then listen via:

ros2 run demo_nodes_py listener
[INFO] [1701855557.054329212] [listener]: I heard: [Hello World: 1]
[INFO] [1701855558.043790308] [listener]: I heard: [Hello World: 2]
[INFO] [1701855559.041985506] [listener]: I heard: [Hello World: 3]
[INFO] [1701855560.044691506] [listener]: I heard: [Hello World: 4]
[INFO] [1701855561.043176148] [listener]: I heard: [Hello World: 5]

which works fine (on fedora 38) on my machine.