System taking a while to boot

Hello, since I reinstalled it, my system is taking a long time to start up.
Here is the systemd-analyse command

Startup finished in 6.939s (firmware) + 7.048s (loader) + 1.956s (kernel) + 4.710s (initrd) + 56.608s (userspace) = 1min 17.264s reached after 56.560s in userspace.

systemd-analyse blame

5.339s sys-module-fuse.device
5.248s sys-devices-platform-serial8250-tty-ttyS1.device
5.248s dev-ttyS1.device
5.247s dev-ttyS14.device
5.247s sys-devices-platform-serial8250-tty-ttyS14.device
5.246s sys-devices-platform-serial8250-tty-ttyS11.device
5.246s dev-ttyS15.device
5.246s sys-devices-platform-serial8250-tty-ttyS15.device
5.246s dev-ttyS11.device
5.246s sys-devices-platform-serial8250-tty-ttyS0.device
5.246s dev-ttyS0.device
5.246s dev-ttyS12.device
5.246s sys-devices-platform-serial8250-tty-ttyS12.device
5.245s dev-ttyS10.device
5.245s sys-devices-platform-serial8250-tty-ttyS10.device
5.245s dev-ttyS13.device
5.245s sys-devices-platform-serial8250-tty-ttyS13.device
5.245s dev-ttyS16.device
5.245s sys-devices-platform-serial8250-tty-ttyS16.device
5.244s sys-devices-platform-serial8250-tty-ttyS17.device
5.244s dev-ttyS17.device
5.244s dev-ttyS18.device
5.244s sys-devices-platform-serial8250-tty-ttyS18.device
5.244s sys-devices-platform-serial8250-tty-ttyS19.device
5.244s dev-ttyS19.device
5.243s dev-ttyS2.device
5.243s sys-devices-platform-serial8250-tty-ttyS2.device
5.243s dev-ttyS20.device
5.243s sys-devices-platform-serial8250-tty-ttyS20.device
5.243s dev-ttyS21.device
5.243s sys-devices-platform-serial8250-tty-ttyS21.device
5.243s dev-ttyS22.device
5.243s sys-devices-platform-serial8250-tty-ttyS22.device
5.242s dev-ttyS23.device
5.242s sys-devices-platform-serial8250-tty-ttyS23.device
5.242s dev-ttyS24.device
5.242s sys-devices-platform-serial8250-tty-ttyS24.device
5.242s sys-devices-platform-serial8250-tty-ttyS25.device
5.242s dev-ttyS25.device
5.241s sys-devices-platform-serial8250-tty-ttyS26.device
5.241s dev-ttyS26.device

I have no idea how or why this is happening

With such a tiny snippet of the output from systemd-analyze blame it is impossible to answer your question. The full output may provide a better clue.
In general, the system always creates many tty devices and as you may note that is only a few milliseconds elapsed in what you posted (and is not during the userspace segment of the boot).

I usually can better analyze what is happening by using systemd-analyze plot > boot-plot.svg then open that boot-plot.svg file in a browser to see where the long delay is occurring. Posting the svg file here would allow us all to see what is happening on the chart and get a better analysis.

Another view would be to use systemd-ananalyze critical-chain and post the output here as preformatted text so it displays exactly as seen on your screen.

Ok, here is
systemd-analyze critical-chain

The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character. @56.560s
└─ @56.559s
  └─plymouth-quit-wait.service @53.313s +3.231s
    └─systemd-user-sessions.service @53.248s +32ms
      └─ @53.228s
        └─ @47.913s
          └─ @47.912s
            └─gssproxy.service @47.885s +25ms
              └─ @47.862s
                └─wpa_supplicant.service @47.896s +14ms
                  └─ @46.283s
                    └─dbus-broker.service @46.252s +29ms
                      └─dbus.socket @46.221s
                        └─ @46.211s
                          └─systemd-resolved.service @46.080s +130ms
                            └─systemd-tmpfiles-setup.service @45.951s +101ms
                              └─import-state.service @45.878s +52ms
                                └─ @45.876s
                                  └─tmp.mount @45.869s +6ms

I can’t upload the svg in the forum, so here is a link boot-plot.svg

From the SVG your system is waiting for 5s for Networkmanager connectivity check, so this issue may be relevant NetworkManager-wait-online.service slow boot times

Thanks, I forgot to disable it. I don’t think it is the only problem

The other thing that stands out are the many disk entries (in the svg), is your disk full/healthy? If you’re on btrfs (for me) trim can help resolve stalls on boot, though I haven’t figured out why as it should be doing it automatically.
Checking nvme health and btrfs status may offer more insight.
Journal size can offer a minor speedup (ymmv), e.g. setting a vacuum size and reducing the current one.

I see that it is taking 30 sec to configure the wifi device then another 14 sec after the vconsole device is configured before continuing with the tmp.mount and following services. This appears to be something related to the network delaying the process.

Yes the network-manager wait online takes 5 seconds but that does not even start until over 54 seconds into the boot.

How can I solve it?

There is this message during startup

I solved the problem, the system was trying to mount a swap partition mentionned in fstab wich did not exist. I replaced the uuid of this ghost partition by the real uuid of the swap and it worked.