Sudden Freezes on Fedora 36 (Plasma)

I did a clean install of Fedora 36 KDE Plasma the other day on my Dell Optiplex 9010 (with an SSD). Everything went smoothly. But yesterday and today, I have had the same issue with sudden freezing. In each case I was doing the same thing when the freeze occurred.

I was running Firefox and Ghostwriter (a Markdown editor). While I was typing in Ghostwriter everything froze. The machine wouldn’t acknowledge any keyboard inputs. And while I could move the mouse cursor, I could not click on anything. I tried switching to another virtual console without success. So in both cases I ended up just powering off the machine and doing a hard reset.

The only thing that I can think of is that Ghostwriter autosaves as you write, and I’m saving into a folder that’s synced to my other computer using SyncThing. I wonder if that might be causing the issue, but I admit this is beyond my area of expertise. Any insights would be appreciated.

Here are my system specs and a link to the log I printed out after the last reset:

Fedora Linux 36
Desktop: KDE Plasma (Xorg)
CPU: Intel i5-4590 (4) @ 3.700GHz
GPU: AMD ATI Radeon HD 8570 / R5 430 / R7 240/340 / Radeon 520 OEM

Me too. When I using firefox, my screen sudden freeze. I can move the mouse after some seconds, but the firefox’s content become blank. And everything become OK after some seconds.
I’m using Fedora 36, Plasma (wayland) 5.24.5, and my GPU is Intel iGPU.

This has been a known issue all along with Plasma, and they still don’t seem to be able to fix it.
I can understand when folks like the plasma look and feel. But the feel gets badly corrupted through laggyness and unresponsiveness. so nothing for your productive work, unless you have a really expensive, new machine maybe.

Thanks for the replies. After doing some more digging, I suspect this may be an issue with the hardware and not the software. I tried installing a completely different distro (with a different DE) on the SSD and the installer froze in exactly the same way. This leads me to believe it’s possibly an issue with the SSD or perhaps the GPU.

I’ve had similar problems lately. You can try to disable dynamic power management (DRM) in the AMDGPU driver. The following command locks DRM to the high profile (until you reboot).

# generic for AMDGPU, non-distro specific
echo "high" | sudo tee /sys/class/drm/card0/device/power_dpm_force_performance_level

It haven’t eliminated the issues for me, but it did reduce the frequency of the freezes and stuttering.

Not sure, if this is related, but I had something similar, caused by my hardware.

No matter what Linux distro or DE – in fact, in KDE I noticed this more frequently than in Gnome, as i915’s power saver feature (psr) kicked in many more times when using KDE.

I could “fix” it by adding i915.enable_psr=0 to kernel via grubby.

Maybe this helps…