Strange behavior on f37 with random short freezings on the system and second monitor shortly disconecting

Hi enlighted people!

I’m not an expert on the matter, and I’m having some strange behaviors on f37, where it randomly freezes for a short time (like for 2 seconds every 4 to 30 seconds). I find it the most annoying when I’m writing something and it gets stucked when the key is pressed, so I get something like “HHHHHHHHHHHHHHHHHHHHHello” (or when erasing)…

Likewise, I also get the second monitor disconnected randomly, specially when just connected, so that I cannot work with it. I’m sure it is not the cable because it was working before perfectly and sometimes, when the screen goes black, I can still see the mouse as well as move it and then it completely disconnects and shows up as if it were just connected.

I also noticed that there are some things that trigger the connection or disconnection of the screen, but it also happens randomly, like said. These are:

  • When the focused window is on the second screen, it helps to stay connected.
  • When the settings of the displays is focused, it stays connected.
  • When I change from full screen to a floating window or vice versa, it has a tendency to get fixed for some seconds.
  • When stuff like the video options or a pop-up disappear, it has a tendency to disconnect if connected or vice versa.
  • When the light of the next room is turned on and off, the screen disconnects.
  • When the screen has no activity and then the image starts to move or vice versa, it has a tendency to disconnect if connected or vice versa.

I believe they have to do with the Panel Self Refresh, that’s why I did what I posted here:

  1. Added this to the grub configuration (sudo gedit /etc/default/grub) : GRUB_CMDLINE_LINUX_DEFAULT="i915.enable_psr=0"
  2. Changed GRUB_ENABLE_BLSCFG=true in /etc/default/grub to false. This had to be done before generating the grub config, or if not I wouldn’t be able to boot into fedora, according to the comments of Neo_Nethshan here.
  3. Then removed old grub config : sudo rm /boot/grub2/grub.cfg
  4. After that, generated new grub config: sudo grub2-mkconfig -o /boot/grub2/grub.cfg
  5. Rebooted my system.

Sadly, after a couple of days I had to undo it because it got worse and I started getting some troubles I had already fixed.

I could not find much more relevant information, so if someone could help me here, it would be really appreciated!

             .',;::::;,'.                akuilera@fedora 
         .';:cccccccccccc:;,.            --------------- 
      .;cccccccccccccccccccccc;.         OS: Fedora Linux 37 (Workstation Edition) x86_64 
    .:cccccccccccccccccccccccccc:.       Host: 82EY IdeaPad Gaming 3 15ARH05 
  .;ccccccccccccc;.:dddl:.;ccccccc;.     Kernel: 6.1.11-200.fc37.x86_64 
 .:ccccccccccccc;OWMKOOXMWd;ccccccc:.    Uptime: 6 hours, 14 mins 
.:ccccccccccccc;KMMc;cc;xMMc:ccccccc:.   Packages: 3390 (rpm), 74 (flatpak) 
,cccccccccccccc;MMM.;cc;;WW::cccccccc,   Shell: bash 5.2.15 
:cccccccccccccc;MMM.;cccccccccccccccc:   Resolution: 1920x1080 
:ccccccc;oxOOOo;MMM0OOk.;cccccccccccc:   DE: GNOME 43.3 
cccccc:0MMKxdd:;MMMkddc.;cccccccccccc;   WM: Mutter 
ccccc:XM0';cccc;MMM.;cccccccccccccccc'   WM Theme: Adwaita 
ccccc;MMo;ccccc;MMW.;ccccccccccccccc;    Theme: Adwaita-dark [GTK2/3] 
ccccc;0MNc.ccc.xMMd:ccccccccccccccc;     Icons: Candy-3D-Originals-grey [GTK2/3] 
cccccc;dNMWXXXWM0::cccccccccccccc:,      Terminal: gnome-terminal 
cccccccc;.:odl:.;cccccccccccccc:,.       CPU: AMD Ryzen 7 4800H with Radeon Graphics (16) @ 2.900GHz 
:cccccccccccccccccccccccccccc:'.         GPU: NVIDIA GeForce GTX 1650 Ti Mobile 
.:cccccccccccccccccccccc:;,..            GPU: AMD ATI 05:00.0 Renoir 
  '::cccccccccccccc::;,.                 Memory: 9580MiB / 15357MiB 


I’m not so sure anymore it is the PSR, since I believe now is properly configured (I’m by no means an expert, and if someone could help me find out what happens, I would be really thankful!)…

I believe the problem could be that there’s not enough power going out of the ports (USB-C and HDMI), since it is when I connect the devices (second monitor and interface) that is specially bad.

When the devices have been long connected, I can work with them, though the Laptop still freezes. The interface (connected through USB-C) is not immediately recognized, and it can take several minutes, maybe even 1/2 an hour, to get recognized and after that it works perfectly.

Like said, I’m no expert, but I believe it can be that since there’s not much power going out of the ports (assuming that’s the case), any little interference, like the lights turning on and off in the next room, can have an impact on the connection.

I also see that the keyboard has some hard time to keep the NumLock and FnLock indicator light on and that’s the reason why I started believing that it is actually a power supply problem…

Is there anyway I can check if that is actually the problem or try to solve it? It is really desperating to try working with a constantly freezing Laptop which doesn’t recognize other devices even if the hardware should work flawlessly =(…

PD: Sorry that I wrote this as a reply, but I could not find the option to edit what I previously wrote

The pencil icon in the line below your post is the ‘edit’ icon.


Sadly, I do not see any pencil on the whole page.

I do see it in this speciiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiific answer though.

Are you by chance running the latest mutter and gnome-shell in Fedora 37?

Can you check you system logs for messages similar to these:

Attempting to freeze the notification queue for object ClutterText[0x5641b693eca0]; Property notification does not work during instance finalization.
Attempting to thaw the notification queue for object ClutterText[0x5641b693eca0]; Property notification does not work during instance finalization.

I had temporarily to rever to an old version of mutter on Fedora 38 Beta and the version I used caused all kinds of issues including lots of slowness and even incompatibility with the gnome portal, preventing apps from opening.

You might be hitting that same issue.

1 Like

You should see something like this for your own post. Note the pencil at the bottom right.

Thanks for the answer!

The gnome-shell version I’m using is the 43.3, which, as I understood, is the latest one.

Sadly, I couldn’t find information on how to check the mutter version, any suggestions?

I could not find such messages in the system logs =/…

Like said and shown in the screenshot, there is no such icon.

Ok, then I have no idea, it’s likely not related to my issue.

Just as a final attempt, post the output of systemctl --failed and also check if gnome-shell works fine without any extensions (if you are using them).

1 Like

Output of systemctl --failed:

  UNIT                  LOAD   ACTIVE SUB    DESCRIPTION          
● nvidia-powerd.service loaded failed failed nvidia-powerd service

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.
1 loaded units listed.

I hope the “failed” ACTIVE and SUB guide to something that can help!

I’ll edit this answer when I start getting the freezings once again and disable the extensions, since they start after some time of the laptop turned on and the more time it is turned on, the worse it gets, and now I have the habit to turn off the laptop every day to avoid the problem as much as possible (still really annoying).


I think it got solved in an actualization though I’m not sure because the laptop looses too much power when the lid is closed and it runs out of energy every night.

It hasn’t had that behaviour anymore since a while ago and it recognizes the inteface as well as the second monitor way faster, though sometimes not instantaniously and the screen still turns off when the light in the next room is turned on or off, and it changes the behaviour depending on how the windows is configured (full screen mode, just on the right, and so on…).

When I fix the power problem and spend a couple of days without becoming the annoying “helllllllllllllllo”, I will post that is solved, even if I still don’t know what the fix was…

That seems to definitely be a power issue. Maybe move the power for the monitor to a different outlet?

Anything that causes an unstable monitor config may cause the freezes as the system tries to reconfigure for changed video output. It could pause everything else as the video is reconfigured then try to catch up.

1 Like

That might be a S0ix problem on your machine, take a look at the S0ix thread for more information:

1 Like

I tried with another outlet, but the problem was still there…

I’m sorry that I explained myself wrong: the 2nd monitor is not turning off is just getting disconnected and in a strange way, since I still can see the mouse pointer when it is “disconnected” as well as move it on the 2nd screen…

The microfreezings happened also when the 2nd monitor was not connected, so it was not the source…

Anyway, at some point the microfreezings stopped but still the 2nd monitor still gets disconnected when the light gets switched :man_shrugging:

This problem got solved with an actualization… Now the laptop behaves as expected with the battery