Spir-V extension required message at clinfo and darktable for Intel A750

I’m at a desktop machine with an Intel Arc A750 discrete gpu that was running Fedora 38 and had intel-compute-runtime and OpenCL worked fine in Darktable. It was last updated about a year ago and when I updated it today to the latest F38 clinfo started saying there were 0 platforms, even when intel-compute-runtime was installed. Darktable saw no OpenCL support either.

So I updated the machine to F40 and the latest packaged DT and intel-compute-runtime and since I asked DT to use Intel drivers for OpenCL it will not start, it merely says

RequiresExtension: Feature requires the following SPIR-V extension:

clinfo (which now reports a platform) gives the same info toward the end of its default output:

  Max work item sizes                             1024x1024x1024
  Max work group size                             1024
  Preferred work group size multiple (device)     64
RequiresExtension: Feature requires the following SPIR-V extension:

If I start darktable with darktable -d opencl it says

     0,0193 [dt_get_sysresource_level] switched to 1 as `default'
     0,0193   total mem:       15844MB
     0,0193   mipmap cache:    1980MB
     0,0193   available mem:   7922MB
     0,0193   singlebuff:      123MB
     0.0204 [opencl_init] opencl disabled via darktable preferences
     0.0205 [dt_dlopencl_init] could not find default opencl runtime library 'libOpenCL'
     0.0205 [dt_dlopencl_init] could not find default opencl runtime library 'libOpenCL.so'
     0.0208 [opencl_init] opencl library 'libOpenCL.so.1' found on your system and loaded, preference 'default path'
     0.0455 [opencl_init] found 1 platform
[opencl_init] found 1 device

   DEVICE:                   0: 'Intel(R) Arc(TM) A750 Graphics'
   PLATFORM, VENDOR & ID:    Intel(R) OpenCL Graphics, Intel(R) Corporation, ID=32902
   CANONICAL NAME:           intelropenclgraphicsintelrarctma750graphics
   DRIVER VERSION:           24.09.28717.17
   DEVICE VERSION:           OpenCL 3.0 NEO 
   DEVICE_TYPE:              GPU, dedicated mem
   GLOBAL MEM SIZE:          7722 MB
   MAX MEM ALLOC:            3861 MB
   MAX IMAGE SIZE:           16384 x 16384
   MAX WORK GROUP SIZE:      1024
   MAX WORK ITEM SIZES:      [ 1024 1024 1024 ]
   USE HEADROOM:             600Mb
   AVOID ATOMICS:            NO
   MICRO NAP:                250
   TILING ADVANTAGE:         0.000
   DEFAULT DEVICE:           NO
   KERNEL BUILD DIRECTORY:   /usr/share/darktable/kernels
   KERNEL DIRECTORY:         /home/to/.cache/darktable/cached_v3_kernels_for_IntelROpenCLGraphicsIntelRArcTMA750Graphics_24092871717
   CL COMPILER COMMAND:      -w   -DINTEL=1 -I"/usr/share/darktable/kernels"
RequiresExtension: Feature requires the following SPIR-V extension:

This might be a query more for …hmm pixls or perhaps phoronix; I don’t know whether it is strictly a Fedora issue. It could be most suitable as an issue for the intel-compute-runtime repo I suppose. Though if anyone else on Fedora has an Intel Arc GPU it they might have seen this. Thanks for reading anyhow : )

I’m not sure whether it’s worth the bump but I tried the same fedora package intel-compute-runtime, same version, on the same Fedora dist (40 KDE) with kernel 6.8+ on a different machine, a NUC12 pro (with Intel Iris XE graphics that have worked with the runtime in the past) and the issue looks to be the same on it, i.e OpenCL unavailable in use and the error message about a SPIR-V extension.

I wonder if the issue is tied to NEO driver not detect GPU when using kernel 6.8.x. · Issue #710 · intel/compute-runtime · GitHub and fixed in the latest version. Will await and see I guess, and if a maintainer sees this and wishes me to test anything I could do that.

I used to be able to run darktable with opencl on Fedora (without intel-compute-runtime) but now it is failing with the same error you get (with and without intel-compute-runtime). Bummer.

Interestingly, I have two kernel directories (/var/user/$USER/cache/darktable/cached_v3_kernels_for_IntelROpenCLGraphicsIntelRIrisRXeGraphics_*): the old one has lots of bin links, the one from today is almost empty.

How were you able to employ OpenCL without an OpenCL driver(intel-compute-runtime for compatible intel gpus)? I can start Darktable without intel-compute-runtime but Darktable detects no OpenCL then, as expected (and the mentioned error is not present).

My system has no /var/user folder.

I’m having the same issue and I’ve trived upgrading to Fedora41 (kernel 6.9) but it doesn’t seem to be resolved.

FEDORA-2024-042ebc3a54 — bugfix update for intel-opencl-clang and spirv-llvm15.0-translator — Fedora Updates System should address this issue.


Well, I know that opencl used to work with darktable on Fedora 39, and I know that I never had intel-compute-runtime (until I tried out for this thread). I do and did have intel-opencl.

I also know that things are borken currently, and that darktable detects opencl even without intel-compute-runtime.

I also know that things work again with the linked update, thanks :slight_smile:

Cool, thanks!
I guess it’ll reach the normal updates shortly?

Yes, the updates were pushed stable overnight, so you should get them as a part of system updates today or tomorrow (depending on the mirrors).

1 Like