Sound not automatically redirected | F40 | Headphones, Speakers

Problem

After installing Fedora workstation 40, the sound output is not redirected automatically to headphones when they are plugged in. When the headphones are unplugged, the sound also has to be manually redirected to the speakers.

Cause

After Fedora workstation 40 installation.

Not yet known.

Related Issues

Not known.

Workarounds

Manual switch from menu settings.

From Proposed Common Issues to Ask Fedora

I have the exact same problem on my Fedora 40 laptop.
The output device does not switch automatically when headphones are plugged in and I need to do it manually.

I wrote a bug for this a while back, see

https://bugs.kde.org/show_bug.cgi?id=486272

In my bug the “not switching to headphones” was mentioned but was just part of the problem. I would plug in the headphones the Pulseaudio Volume Control “Output Devices” would have the headphones in the list but would not automatically switch. So if I manually selected the headphones, the playing video would not play in the headphones. I had to manually run:

systemctl -l --user daemon-reload; systemctl --user restart wireplumber pipewire{,-pulse}

to restart the pipewire/wireplumber. The sound would then play but there would be a nasty plasmashell core dump/crash. So Bug 486272 is mainly about having to restart pipewire and getting a plasma crash but a side issue is why is the output device not switching.

1 Like

This should also include a “Default Audio Device” setting that when bluetooth or other non-local speaker is disconnected the sound dialog either demands your choice or defaults to aka laptop speakers(internal sound)

Added bug-reported and removed wayland, workstation