Some flatpak apps windows go beyond the screen

I have this problem of some apps windows go beyond the computer screen when they start. Both of the apps i have experienced this problem with are flatpak apps.

This is how the Element app windows appear when it starts:

And this is Gittyup:

For example nheko is installed the flatpak version and it does not have this problem.

Another example of an app windows acting weird is the Problem Reporting app, this is how it appears when it starts:

And this is how it is suppored to look like:

Note: Problem Reporting app is not a flatpak app

I don’t have this issue with Flatpaks on KDE. I’m running an X11 session, are you on Wayland? Do you have any non default config like fractional scaling?

No everything is default, i just installed fedora from a couple of days. I think it’s a problem in Wayland, will try to switch to X11 and see what happens.

Unfortunately i can’t find a way to change to X11 from wayland.

Logout from the current session, in the bottom left of SDDM login screen there must be an option: Plasma session (Wayland). Click on it, select X11 and then login again.

1 Like

I saw them before but thought they were just text not buttons i can click, they dont look like buttons:

When i changed to X11 the apps that were having problems now work fine. The windows are in the screen now and display well.

I lost the ability to disable my laptop’s touch screen tho

Good to know, Plasma is still buggy on Wayland. Support will be better with Plasma 6.

You should probably mark the reply as answer (though it is more of a workaround).

1 Like

I solved the problem temporarily while using Wayland in this following manner.

  1. Right click on the window frame and choose the following option


  1. This window will appear

  1. Add these settings


This worked for Gittyup but not element. Element crashed while doing the tweak above. Also i think you will have to do this for every app that has this behavior.

Great! mark this as the solution (for future reference).

I think what you wrote and i marked as an answer is the better solution right now. Using X11 is better to do for most people i think. It’s just my choice to use wayland and do this window tweak i mentioned above, cuz wayland is faster.

A bit off topic, how are you tolerating the Wayland session? It is pretty annoying in my experience, kinda laggy and the window activation issue annoys me too much.

More info: Plasma/Wayland Showstoppers - KDE Community Wiki

1 Like

For me it hasn’t caused any problems other than the one i mentioned above. In some parts it’s faster, like when locking the screen, it’s faster than x11. If i experience more problems with wayland, i will change back to x11.

I gave it another try now, the activation issue is no more. That is some progress.

I can’t wait for Wayland to become as good as X11.

1 Like

There is another easier solution that seems to be working well

  1. Go to Settings > Display and Monitor > Display Configuration
  2. Search for Legacy Applications (X11)
  3. Change it to Scaled by the system

The apps windows should now size well

Note: If the apps are already working well, do not do this as this may make some apps blurry and crash others