Software updater stuck in rpmfusion-free and nonfree updates for Silverblue 35

For several days (or weeks), I have noticed a warning in Software to update rpmfusion-free-release and rpmfusion-nonfree-release, from version 35-0.2 to 35-1. Once done, the notice vanishes but then reappears when new updates are announced (example attached). Any way to fix this? Thanks in advance.

repos need updates

Silverblue is immutable and normal repo updates wont work. While software center is a nice to have, you will need to learn to love the terminal. Recommend the following:

Open a terminal, type in sudo rpm-ostree upgrade

After finishing, reboot into the new system image. This should solve your problems.


1 Like

I need to chime in here with a Q: Should applications from 3rd party repos in a Silverblue environment be better installed in a toolbox/ podman instead? I mean if the OS is to be kept “clean” the only thing you should need from a 3rd party would be drivers (gpu etc…)

I agree. Everything should be sandboxed and installed via flatpak or the like. The question was regarding the users desire to fix the gnome software bugging out and them using 3rd party repos.

Incorporating the rpmfusion repos in the ostree will work and likely safe, but it does go against the idea of an immutable system.

I was genuinely curious, I don’t use Silverblue daily but i have a conceptual Silverblue build.

For the first time in MANY releases, i had a issue with gstreamer-1 wreaking havoc on my latest build. I had to disable all the 3rd party repos and exclude gstreamer because of it. The update outside of it went through, but I couldn’t imagine what that would mean for an rpm-ostree build.

I actually love the terminal and tried your suggestion several times before this post. This morning Software was reporting some updates, including rpmfusion-free-release and rpmfusion-nonfree-release, from version 35-0.2 to 35-1, again. I ran rpm-ostree upgrade and it worked as usual, installing all updates (with no mention of the rpmfusion updates). Then I rebooted and checked Software, which reported everything up-to-date. Several ours later, rpmfusion updates available announcement is back again, like a ghost.

I personally don’t use silverblue. Can you remove the rpm fusion repos, do the equivalent to a distrosync in rpm-ostree. Reboot into the new image, check software again, the re add the repos… Just an idea

You may want to take a look at: Simplifying updates for RPM Fusion packages (and other packages shipping their own RPM repos) - Silverblue - Fedora Discussion

Thanks. I found a similar solution that also worked. I will explain it in another post.

I followed your lead and fixed the problem. But then, I hit another issue, this time Software and rpm-ostree complaining about lost GPG keys. Looking around, I found and then applied these commands:

sudo rpm-ostree install

Afterwards, I tried both Software and rpm-ostree several times since last night without a single incident, and even this morning I applied updates with Software, again without any issue.
Thanks for your time and support.

1 Like