Screen resolution on F34


I just upgraded from Fedora33 to Fedora34 using dnf system-upgrade, and now the graphical interface only uses a part of my monitor, leaving the right side and bottom black. If I move windows right or down, they don’t go to the black area, they are just cropped.
I have an Intel core 5 processor with an integrated graphics processor, and I boot to the command line and use startx to go to the graphical interface. I use KDE.
The Display Configuration in System Settings / Display and monitor shows that I have the display at 1024x768 resolution, and the resolution pulldown menu doesn’t offer anything else.
The monitor itself is in 1680x1050 resolution and connected with a DVI-D cable, and the text mode virtual consoles use the whole screen.
Where should I start configuring to get the whole screen back again?

1 Like

The Adding undetected resolutions section of ArchWiki’s xrandr guide is probably what you are interested in. Arch Linux is also an RPM-based distro, so oftentimes their guides work on Fedora Linux without modification.


I checked the ArchWiki page.
Got the ModeLine with cvt, tried to give xrandmode --addmode XWAYLAND0 instead of VGA1 as that’s what xrandmode --listmonitors gave.
The xrandmode --output didn’t work, it said “X Error of failed request: BadValue (integer parameter out of range for operation)” when I had given the --addmode the parameters from the cvt output.
The “Permanently adding undetected resolutions” section says I should edit /etc/X11/xorg.conf.d/10-monitor.conf but there is no such file and wasn’t before the system-upgrade (I checked my /etc backup from April). I tried to create one, but it didn’t help.

Someone else reported similar errors here recently:

You might compare what you are doing with what they did an see if you can find a common cause of the error. Also, you might ask them if they were able to figure out the solution. Sorry, adding undetected modes isn’t something I’m experienced with.

There is a way to generate the file, but you wouldn’t want to do that until after you get a working modeline with xrandr.

1 Like

Because this happened after system-upgrade without me changing any settings myself, I filed a bug report


The problem got fixed with my newer (built last June) computer on Wednesday the 4th of May when I updated xorg-x11-xinit to 1.4.0-10 (and fstrm to 0.6.1-2 in the same transaction), but my older computer, built in December 2009, still only used part of the screen with X.
The older computer got the problem fixed on the 8th of May, when I got updates for the plasma packages (5.21.5-1 on some and 5.21.5-3 on some others), kde-gtk-config (5.21.5-1) and breeze-gtk-* (5.21.5-1), not sure which of them was critical as I updated them in the same transaction.