Running Victoria II (an ancient 32bit game)

Hey all,

I come to you in desperation. Victoria II is an old 32bit windows grand strategy game, that did work on Mac for a time being. It is one of my favourite games, and I am truly desperate attempting to find a way to still play. I managed to get the base game working on my Mac (a 2021 M1 16" Pro) using crossover/wine, but the base game is rubbish (borderline unfinished) yet the community modding scene is incredible - yet for some reason the game never works when I load a mod on my Mac, and I have tried every possible fix.

I believe that the original is just a DirectX game, however some dedicated modders are working to reverse engineer the game in C++ using OpenGL (incredible). I cannot express how badly I want to get in.

I don’t have Asahi on my Mac (yet) and that is why I am posting here to ask. What hope do I have of running it? Would wine emulation of 32bit work in Asahi? Would anyone (if I ask them incredibly nicely) be willing to try, or has tried? I would love a hand, the linux world is very new to me but I am certainly a ‘power user’ as they used to be called, so I’m sure ill wrap my head around it in time.

1 Like

I guess give it a try? Asahi can be installed and uninstalled again. 32bit games work fine in WINE, but no idea about x86 emulation on ARM.

That would be the bigger problem.