Rpm-ostree upgrade has very slow download speeds

When I issue an rpm-ostree upgrade command in a terminal, the first parts of the download were very fast but as the download progresses the speed dropped mostly down to 10-40 KiB/s (see attached screenshot)

Apart from that, I periodically get error message similar to this one in journalctl:

Jun 22 16:08:06 lumine rpm-ostree[3210984]: libostree HTTP error from remote fedora for <https://d2uk5hbyrobdzx.cloudfront.net/objects/b2/97ad4a2e28620f307fbb5ad6dd99abead611561a93efc48bd9d1b6631e2039.filez>: Stream error in the HTTP/2 framing layer
Jun 22 16:08:06 lumine rpm-ostree[3210984]: Txn Upgrade on /org/projectatomic/rpmostree1/fedora failed: While pulling fedora/40/x86_64/silverblue: While fetching https://d2uk5hbyrobdzx.cloudfront.net/objects/b2/97ad4a2e28620f307fbb5ad6dd99abead611561a93efc48bd9d1b6631e2039.filez: [92] Stream error in the HTTP/2 framing layer

When I try downloading that https://d2uk5hbyrobdzx.cloudfront.net/objects/b2/97ad4a2e28620f307fbb5ad6dd99abead611561a93efc48bd9d1b6631e2039.filez manually with Firefox, I get same bad speeds.

This happened across many network connections from different ISPs, ranging from my apartment’s Wi-Fi, my 5G mobile data, to my corporate Wi-Fi. All from Bangkok, Thailand.

I tried using aria2c -x16 to download that particular 133MiB file. During first 20MiB the speed was about 1.5MiB/s after that the speed dropped rapidly to ~100KiB/s.

This makes upgrading 3 of my Fedora Silverblue/Kinoite boxes take a very long time at ~30KiB/s. It’s been more then 2 hours and the download hasn’t finished yet.

I tried pinging d2uk5hbyrobdzx.cloudfront.net and this is what I’ve got:

64 bytes from server-18-172-0-69.bkk50.r.cloudfront.net ( icmp_seq=1 ttl=244 time=38.2 ms
64 bytes from server-18-172-0-69.bkk50.r.cloudfront.net ( icmp_seq=2 ttl=244 time=34.5 ms

I was downloading it from brazil and it went very fast. But I guess it is because it is cloud-front. Could be mirrored worldwide and my connection might be faster as yours.

I had this a long time to, that my connection went fast and then got a slow down. Now i do have fiber optic and in general my connection is much faster.

Never less, have you tried with an free vpn (proton vpn as example) to see if you get better speed? It is strange that you checked with several IPS and got same slow speed.

I tried using Proton VPN with a JP server and the result was similar, but for NL server the speed went up to like 1MiB/s which is usual for my apartment’s WiFi. Something’s probably wrong with the CDN on East Asia regions.

I’m also fast with a Brazilian VPN, so your guess is probably correct.