RPM-Fusion Repo not getting Updated

After adding RPM Fusion Free repository, (In root)
dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm

When I try to install something with

dnf install xyz

The usual repository update process doesn’t update RPMFusion. It just gets stuck there.

How can I Fix this?

Fedora 31 - Command-line

Try sudo dnf clean all && sudo dnf update

Can you also post /etc/yum.repos.d/rpmfusion-free-release-31.repo? (You can compare it with the source here.)


Thanks a lot!
clean all worked for me.


That gives no such file or directory error.

It’s actually just


I tried those commands and everything went well but then Fedora couldn’t restart and got stuck for awhile.

So, I found out ctrl+alt+delete works in Fedora too.

Everything back to normal now, no worries!

Next time it is stuck for a while, press the ESC button to see what’s going on. It sometimes happens that processes wait for other processes to be terminated (like 60, 90 or 120 sec).
The same can happen at boot time, you may think it is stuck but the system is just rebuilding a kernel module (try to hit ESC while booting and you see what’s going on…)

instead of this, next time hit ctrl+alt+F3, then login and shutdown your machine (or whatever else):

/sbin/shutdown -h now
1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.