RDP on Fedora Silverblue?

I am running Fedora Silverblue 38.20230923.0. I want the device to be headless. I have configured SSH, but I also need to use the GUI from time to time, so I need to enable RDP. I went into the Settings Sharing, and enabled Remote Desktop and Remote Control.

I can only RDP onto the device when I am logged in locally on the device. As soon as the screen locks, I am kicked out, and not allowed back in. This is weird, but apparently as designed. Is there any easy way to just allow RDP to work normally on a headless device?

Reading forum posts for Fedora, it seems like I need to install xrdp. But sudo apt does not work on silverblue. Is this something that I must install using rpm-ostree? Last time I installed anything with rpm-ostree, it locked me out of rebasing the OS to 38, so I am trying to avoid that where possible.

I am still learning linux, and Fedora, and the Silverblue version, so any help or pointers would be greatly appreciated.

I also searched for this some time ago, though mine was fully headless (no monitor or plug). Seems that headless session is not supported yet. Not sure if these are relevant:

p.s. The issue preview is wrong and shows both as #90 for some reason…

Using silverblue it seems that rpm-ostree (and ostree) are the only way to do system management.

I suggest that instead of avoiding it you instead learn to properly use it.

I cannot assist with the RDP question.

At my former work, everyone was issued a Windows laptop with an “enterprise” image. Some users worked with applications on an enterprise datacenter cloud. RDP was available, but so laggy as to be useless, so web-based remote access (Jupyter, Rstudio, etc.) were more effective.

Consider to enable auto login and disable screen lock on timeout.

One thing that can help you is an extension for enabling access even if your screen is locked, but it’s still not the full “access even if I’m not logged in as my user” that I imagine you’re looking for.