Public ssh key file type confused with A PUB file

I’ve logged into the FedoraGitLab account to work with Docs subgroup.

To follow git workflow, my ssh key is copied and pasted to GitLab, but I found out my public key file type is changed to Microsoft Publisher document (application/

The file association wasn’t a problem until today.

Pub key file is not opening.

OS version: 36.20220614.0 (Silverblue)

Could you advise a work-around?

Can’t you copy the pub key from gitlab?

I didn’t add the pub key to gitlab before.
I copied it from Pagure, and pasted it onto gitlab, but it is not recognized as a key pair.

ssh-keygen -y -f ~/.ssh/“yourcert” > ~/.ssh/

you’ll want to move or remove the empty pub file

I realized the file type association in Nautilus does not matter.

  1. To see the key
    cat ~/.ssh/

  2. Copy everything to SSH Keys - ‘Add an ssh key’ in gitlab user settings.

  3. Click ‘add key’


Sorry, I misunderstood. I thought your key was blank.

Glad it’s fixed.