Problem with new kernel boot loader

I have a problem like this.
Mine isn’t a grub.cfg problem, it is a problem with whatever is supposed to manage /boot/loader/entries. Here’s what I tried to post yesterday but was prevented by this site’s machinery:

The essential problem is that /boot/loader/entries has no entry for the newly installed f36 kernel.
RPM says that the kernel is installed. It looks to be
The system is f36 but it is running on an f35 kernel.
I tried to fix this via “dnf reinstall” the f36 kernel, and that did reinstall the kernel, but no entry showed up in /boot/loader/entries

Why did this happen?
What is the right way to fix it?

Since yesterday, I did a “dnf update”. It installed the latest kernel and removed the oldest.

It removed the oldest kernel’s entry from /boot/loader/entries but did not add an entry for the newly installed one or the one installed by the upgrade to F36.

What is resposible for updating /boot/loader/entries?

You are posting on a thread that is for F35 and F34 while you are posting a problem with F36.

Please open a new thread for your specific issue.

Good point. But I’m not allowed to.

And why do you say that.
Every user on this forum is able to start new threads.

I’m a new Fedora user, but with a few experiments, from what I understand, setting GRUB_ENABLE_BLSCFG=false doesn’t upgrade the grub configuration automatically when you install a new kernel. As it was said, you have to recreate the grub configuration yourself

Topic split from