Problem with creating a Samba share via gui with KDE


I’m relatively new to Linux and did the switch from Windows to Linux on my main PC. I’ve settled on Fedora KDE Spin and had running version 36. I did the 37 update recently, all is good. I’m still experementing and learning stuff, so far no big problems. I’m currently dealing with Samba (shares). I have a second Windows PC and I want to create a Samba share on Linux so the Windows PC can access it.

I followed the instructions from the docs, specifically the part “Sharing a directory inside /home”, which is what I want to do.

I managed to get this working. Then my question was if there is a more easy way, similar to Windows, to create a share via gui, for example in Dolphin, right click - > Samba share or smth. Because it’s a bit tedious to go through these steps for each new share.
I asked on reddit about it and a helpful user pointed me to the kdenetwork-filesharing plugin for Dolphin.

But I’m having problems setting it up. After installing the plugin I can see a new “Share” tab in the properties of a folder. But all I get there is the following:

Thank you!

I don’t use that to share files with samba but have you set up a samba user.You can do that in the terminal with smbpasswd -a yourusername
You can also open system setting go to network settings windows shares and set up a user and password there.As I said I haven’t used that plugin but samba works well for me but I have the shares set up in smb.conf

Yes, I have set up a Samba user and created a share in my home directory via the smb.conf file, like descriped in the linked documentation of Fedora. That does work, I can access the share on my Windows PC with the created Samba user.

My problem is the usage of the plugin. And yes, I tried to insert the name and password of my Samba user under system settings - > network - windows shares, but that didn’t help, though, I don’t even know if that even has something to do with the plugin.

The only other thing I can think of is make sure your a member of the sambashare group.I really don’t know what permissions that plugin needs.Maybe someone who has gotten it working will post how they did it.

Yeah, I will probably ask on KDE reddit about it. Someone has to know how it is supposed to work.

Because you are mentioning a “sambashare” group:

Initially, I didn’t have a sambashare group, as there is no instruction in the documentation to create such group for a share in the home directory (only one user). But a reddit user also mentioned to add my user to the “sambashare” group. So, because of the absence of such group, I created a group called “sambashare” and added my user, which is also a Samba user, to this group. Additionally I modified the permission to 770 for the shared folder.

But that didn’t help either.