Powerbeat Bluetooth Headphones

Having trouble connecting my Powerbeats Bluetooth headphones. To be fair, over the last two years, I have used Ubuntu and POP_OS, which never connected to the headphones, and Manjaro KDE which worked perfectly with basically no set up. This might be a Gnome issue, but after switching to Fedora 34 yesterday, which I am loving, still no working headphones.

The Settings->Bluetooth app finds the headphones but never connects.

I was able to go to the CLI, user bluetoothctl and find the hardware device, and pair using bluetoothctl pair DEV_ADDRESS. But when I open the Bluetooth GUI and click the device, it is paired but not connected. It does not show up in the Sound app to select as a deveice.

Any help would be appreciated.


First of all, open the GNOME settings menu and go to the bluetooth section. Then remove the powerbeats (you have to try a reconfiguration from scratch entirely using the command line). Close the settings window.

To investigate open two terminals:
In the first terminal type the command sudo journalctl -f
In the second terminal type:

bluetoothctl ↵
scan on ↵
connect DEV_ADDRESS ↵
exit ↵

Look at the first terminal to see what happens.

I also had a hard time connecting the Powerbeats with bluetooth, but after a few attempts I made it.

In case you want to cancel the pairing or the connection there are two commands, respectively cancel-pairing DEV_ADDRESS and disconnect DEV_ADDRESS
Good luck!


@lalincedeldeserto thank you this does give more information. The relavant part of the journal ctl command:

Jun 15 07:32:04 fedora bluetoothd[89552]: Failed to set privacy: Rejected (0x0b)
Jun 15 07:32:04 fedora pipewire-media-session[2141]: native: Unregistering Profile /Profile/HSPHS failed
Jun 15 07:32:04 fedora audit: BPF prog-id=117 op=LOAD
Jun 15 07:32:04 fedora audit: BPF prog-id=118 op=LOAD
Jun 15 07:32:04 fedora pipewire-media-session[2141]: native: Unregistering Profile /Profile/HFPAG failed

It seems to pair and connect, according to bluetoothctl but no Audio option in Settings->Sound

Correction its working. I just had to select the correct profile in Settings->Sound.
@lalincedeldeserto thanks for your help.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.