Phone not showing up when plugged in

My phone doesnt get picked up by fedora, using “dmesg; lsblk” get a device not responding to commands.

The stupid question, but just to make sure. On, for example, some android phones, once you plug in the phone you have to, on the phone itself, choose to allow file transfer.
It’s working fine for me, both on a default workstation install and a moderately minimal install with simple-mtpfs installed and working on CLI if i want to transfer files on an aging Google 3a Pixel.

1 Like

There is no popup on my phone to do that. I even have usb debug. My friend suggested mounting it to /dev/…

It may only be a Pixel thing, I don’t know. It’s not a popup actually, once I plug it in, I have to unlock the phone and swipe down, then it becomes visible as a notification that it’s charging via USB and has a down arrow. I tap the arrow and it says tap for more options, from there I can chose to use it for data transfer. It’s not at all intuitive, and again, it might just be a Pixel phone thing

Thats what happened when i used ubuntu. But with fedora nothing…

Are you using the default Fedora Workstation? If you had the time and inclination, it might be worth filing a bug then. If it does turn out to be something that is some peculiarity of your system, what I usually call a Just Me Problem ™ there may be no good answer, but if it is a bug that others can reproduce, it might be worth reporting at I don’t know, as I’ve mentioned I can’t reproduce the problem. The fact that it does work on Ubuntu, however, indicates that it might be a Fedora issue.