Permission denied: unknown with docker on Fedora 34

Today, after update Fedora 34, docker no longer run and show the following error:

docker run -it --rm alpine /bin/sh
docker: Error response from daemon: OCI runtime create failed: container_linux.go:380: starting container process caused: process_linux.go:545: container init caused: process_linux.go:508: setting cgroup config for procHooks process caused: cannot fetch program from id: get program by id: permission denied: unknown.

The same error occur when running docker with sudo. I try to uninstall docker removing all files withou results.
So, changing the permissions of docker.socket take the same effect:

sudo chmod 666 /var/run/docker.sock

The error persist.

Thanks for help.

1 Like

Same error. Try to uninstall/install, clear data but keep to fail.

Hello, I had the same issue, I found a solution here :

Basically, you need to downgrade back to version 1.4.8 ( sudo dnf downgrade

1 Like

Nice! Works for me.

sudo dnf downgrade