Package database problem - warning: bdb Pakckage database found…SQLLite

, ,

I upgraded from F32 to F33 earlier in the week and ran my first (successful) update today. In the process I noticed DNF “warning: bdb Pakckage database found…SQLLite”. So DNF used the bdb package database and updated packages anyway.

A day or so ago I had tried using DNFDragora to perform upgrades and it failed partway through. Actually, the machine lost the wifi connection to the Internet repeatedly. So it is possible that the failure corrupted a setting, although I don’t know why DNFDragora wouldn’t agree to use the SQLLite db that DNF / RPM use.

I researched the problem on Bugzilla and found this has been around since 2015 or so. I tried the suggested remedy - rebuilding the RPM database, but I was denied access to the database and the command failed.

I have also begun seeing other database access failure warnings as well, related to application access to certain files. Something is screwed up here. A first step would be to get rid of bdb; can someone advise how to do that?



Please check this:

And the bug attached to it:


and also the workaround in the bug attached…


1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.