OpenVPN connection unresponsive after some minutes in F31


Hello all,

I have recurring problems with my openvpn connection: I can connect and use it but it crashes (without any obvious notification) after a few minutes. During the first few minutes I can use it normally to connect to IP-restricted servers or use the browser but afterwards any websites load forever and the connections to servers are unresponsive/freezed (but not time-out or broken pipe).

What I have:

  • x.ovpn file with some pre-defined settings including three keys/certs from the openvpn provider.
  • Fedora 31 (Linux 5.5.8-200.fc31.x86_64)
  • installations as recommended here (sudo dnf -y install openvpn NetworkManager-openvpn NetworkManager-openvpn-gnome)
  • restorecon -Rv /home/plant42/.cert/ (according to here, did not help)

What I tried:

  • sudo openvpn x.ovpn
  • GUI interface (with “import file”)
  • nmcli connection import type openvpn file x.ovpn; nmcli connection up x

For me, they all result in the same problem which I had in F30 and F31. Sometimes, very rarely (and if I have the passion to wait), the connection comes back for some minutes which seems really weird to me.

I only can use “normal” internet again if I literally kill the openvpn process with sudo kill -9 $(pgrep openvpn) or reboot.

I thought about bandwidth issues or limiting the vpn usage only to the IP (of a server) that I need at the moment. Both did not help: either it was not the root of the problem or I did a wrong set up.

Could you please help? Please let me know what kind of logs or additional system information are required as I am not good in connection issues.

Thanks a lot!

Do you use an Ehernet connection, or wifi? I once had similar problems, where I was always disconnected/reconnected without actually being able to open a website. The problem was that my wifi was to unstable. But that was with a Cisco VPN, not OpenVPN.

Thanks for your suggestion. I tried it and it worked a bit longer than only via WiFi but freezes again. However, it comes back more quickly. At least I can work on a low level but this and the “hard” connection is quite annoying.

My colleagues are working with similar machines on Windows OS using the same type of OVPN files but they do not have connectivity issues.

Therefore I assume my problem is related to Fedora settings or configurations. I can remember that I did not have such a problem with previous Fedora versions on the same machine.

Do you (or anybody else) have a guess?

And – I know this is not related to Fedora issues – maybe any hints for tuning my VPN usage?

First of all: I am definitely not an expert in networking.

Have you tried the instructions from the Fedora Wiki?

Perhaps you just have to enable and start the systemd service?

Anyway, the log file at /var/log/messages might help. What does it say?