OBS Virtual cam on Fedora 33

Hi everyone, I am new to here and also relativly new to Fedora.
I install Fedora 33 about 1 and a half month ago and I installed OBS. I want to use OBS virtual cam like I did on Ubuntu. I know that it isn’t nativly supported on linux, so i tried this tutorial (I used it on ubuntu 20.04) Broadcast from OBS Studio To Everything In Linux
I know that it is made for Ubuntu, so I tried using dnf instead of apt-get etc. but there is much more things different in Fedora, kernel modules are elsewhere, no apt-get, something not working…

So please help me.


This may help you get in the right direction: https://copr.fedorainfracloud.org/coprs/sentry/v4l2loopback/

dnf copr enable sentry/v4l2loopback 
sudo dnf install v4l2loopback
modprobe v4l2loopback

You may need to reboot for the module to be loaded properly


Thank you for your help, but this wasn’t exactly what I wanted, It’s very helpfull and I need it,
but I have more troubles installing OBS plugin GitHub - CatxFish/obs-v4l2sink: obs studio output plugin for Video4Linux2 device
because there is no sudo apt-get install libobs-dev and when I try to build it, i ran into error missing libobs

Do you know how to fix this ?

Thank anybody for any help


all you need is find out the similar package in :fedora: because you’re following a debian/ubuntu way.


  • QT
sudo dnf install qt5-qtbase-devel
  • Install LibObs
sudo dnf install obs-studio-libs
  • And continue with the build…
git clone https://github.com/CatxFish/obs-v4l2sink.git
cd obs-v4l2sink
mkdir build && cd build
cmake -DLIBOBS_INCLUDE_DIR="../../obs-studio/libobs" -DCMAKE_INSTALL_PREFIX=/usr ..
make -j4
sudo make install


1 Like

Hi, I tried installing using process that you sent, and when running cmake it gave me this error
– Could NOT find Libobs (missing: LIBOBS_LIB)
CMake Error at external/FindLibObs.cmake:106 (message):
Could not find the libobs library
Call Stack (most recent call first):
CMakeLists.txt:6 (include)

– Configuring incomplete, errors occurred!
See also “/home/cyril/Downloads/obs-v4l2sink/build/CMakeFiles/CMakeOutput.log”.

What should I do now ?

Btw. contenst of that CMakeOutput.log are here The system is: Linux - 5.10.9-201.fc33.x86_64 - x86_64Compiling the C compiler - Pastebin.com

Thank you for any help

Please do this, and you don’t need to install anything or compile something:

  1. You can download the deb. from gtihub:
  1. extract it
ar -xv obs-v4l2sink.deb

You will get two compreses folder:

  1. control - hasn’t got any special .

  2. data - here is where the plug-ins live, just extract with double-click and extract here.

  3. Find the plug-in:

cd data/usr/lib/obs-plugins
  1. in :fedora: obs-plugins live or are locate is here ls /usr/lib64/obs-plugins, procede to move it.
sudo mv v4l2sink.so /usr/lib64/obs-plugins/v4l2sink.so
  1. Start obs-studio:

  2. Go tools and and you can see v4l2sink there.


Easy isn’t it. :partying_face:

I tested the steps below inside a container.


The idea come from here:

Altought I have tried to compile without sucess in :fedora: 33. The solución offers there is about of compiling against a patch plugin for the versión of obs-studio offers in :fedora: 32.



It should be noted that OBS now comes with a v4l2loopback virtual camera built-in
Simply installing OBS-Studio and v4l2loopback should do the job


uhm, you’re right

When you select Source:

video capture device V4L2


This has been integrated into the main OBS build as of 26.1.


Hm, I am following the steps and do find v4l2sink in /usr/lib64/obs-plugins. But in OBS at tools I cannot find the sink.

Please, provide the following:

rpm -qa obs-studio
ls /usr/lib64/obs-plugins/


1 Like

this helped a lot.
I have installed OBS from another source/flatpack (I think because the default OBS software did not easily allow interfacing with wayland [if you know how to get wayland to work with OBS from non-flatpack, I am happy to learn]).
I found OBS with its flatpak based plugins directory, moved v4l2sink.so there and then it worked.

as root

  1. cd /
  2. find . -name "obs-plugins"
  3. locate flatpak folder
  4. copy v4l2sink.so to flatpak folder
    4b. ensure that you do not have some kind of similar file in that folder like obs-v4l2sink, which might be a non-functional symlink.
  5. modprobe v4l2loopback card_label="Virtual Cam" exclusive_caps=1
  6. start OBS
1 Like

I have made all these steps at F33, with no success. I can get capture device v4l2, but any virtual cam. I read at git that plugin for v4l2sink for Linux is still under development. Any hint?

It is not working properly. I followed these steps, and what I got is an instance of OBS Studio running system wide, accessible only for root. In this case everything flows smootly. However there is an instance running in my home folder with no access to virtual cam. I guess that when issuing this command:

sudo mv v4l2sink.so /usr/lib64/obs-plugins/v4l2sink.so

the instance at root is activated. Of course that I want OBS Studio running under my /home/username/

Any hint?

Thank you.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.