Nvidia GeForce GTX 1650 mobile driver

I have Asus FX 505DT laptop and I’m trying to install Nvidia GeForce GTX 1650 driver. I’ve already tried to install it via rpm, but it worked incorrectly, some games and apps that I’ve played with Nvidia mx 130 using proton on this laptop aren’t working. Also I tried to install it manually, I tried to install 470.xx driver, but my loading stuck. I see the logo and nothing more.


What repo did you try installing from? rpmfusion?
What repos do you have enabled? Post the output of dnf repolist

You said you are using proton. Does that mean you are using steam? or something else? If using steam where was it installed from?
Please post the output of inxi -Fzxx so we can see a little bit about your system. (you may need to install inxi)

Is your fedora system fully updated? sudo dnf upgrade

1 Like

I’ve used this installation manual:

So, I’ve downloaded the 470 driver from Nvidia website.

The 470 driver does not allow you to use wayland and leaves you using xorg only. That may or may not be an issue for you, but you should know that up front. The newer 495 driver on fedora does allow the use of wayland on nvidia.

Try removing the driver installed from the nvidia site then follow the instructions below to install from the rpmfusion repo.

A very large advantage to installing the driver from rpmfusion is that with every kernel or driver update the new kernel modules are built automatically, while installing from nvidia requires you to manually build the modules every time there is an update.

To install the nvidia driver from rpmfusion there are only 3 steps involved.

  1. open the gnome software panel and enable the 3rd party repo rpmfusion-nonfree-nvidia (if using steam then enabling the rpmfusion-nonfree-steam repo at the same time may be of benefit as well)
  2. sudo dnf upgrade
  3. sudo dnf install akmod-nvidia

The 3rd step will install the newer 495 driver that both supports your GPU and allows either wayland or xorg to run on the nvidia card.

If you are using steam as your first post seems to indicate, (but you did not specify), then you should remove steam you already have installed and install it from the rpmfusion repo with sudo dnf install steam. The package installed from there is tested and configured to work on fedora. For me steam works best using xorg and not wayland.

Thank you for your reply. I’ve installed steam via software app and tried to install 495 Nvidia driver using rpm repo before, but I had a problem with shaders support, so I tried to install it from official website. I’ll try your solution later.

I’ve tried to install so right now, but when I’m starting stalker clear sky it says that pixel shaders v 1.1 are required. I’ve used proton 6.3.8 and 3.7.8, but it says the same info.

In addition I added info you asked previously
Kernel: 5.15.18-200.fc35.x86_64 x86_64 bits: 64 compiler: gcc
v: 2.37-10.fc35 Desktop: GNOME 41.3 tk: GTK 3.24.31 wm: gnome-shell dm: GDM
Distro: Fedora release 35 (Thirty Five)
Type: Laptop System: ASUSTeK product: TUF Gaming FX505DT_FX505DT v: 1.0
Mobo: ASUSTeK model: FX505DT v: 1.0 serial:
UEFI: American Megatrends v: FX505DT.316 date: 01/28/2021
ID-1: BAT0 charge: 42.4 Wh (99.3%) condition: 42.7/48.1 Wh (88.7%)
volts: 12.9 min: 11.7 model: FX50442 serial: N/A status: Charging
Info: quad core model: AMD Ryzen 7 3750H with Radeon Vega Mobile Gfx
bits: 64 type: MT MCP arch: Zen/Zen+ note: check rev: 1 cache: L1: 384 KiB
L2: 2 MiB L3: 4 MiB
Speed (MHz): avg: 2727 high: 3993 min/max: 1400/2300 boost: enabled
cores: 1: 2661 2: 2661 3: 3993 4: 3992 5: 2661 6: 2660 7: 1597 8: 1597
bogomips: 36731
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: ASUSTeK
driver: nvidia v: 495.46 bus-ID: 01:00.0 chip-ID: 10de:1f91
Device-2: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Vega Mobile
vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 05:00.0 chip-ID: 1002:15d8
Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
bus-ID: 3-1:2 chip-ID: 13d3:56a2
Display: x11 server: X.Org 1.20.14 compositor: gnome-shell driver:
loaded: amdgpu,ati,nvidia unloaded: fbdev,modesetting,nouveau,vesa
alternate: nv resolution: 1920x1080~144Hz s-dpi: 96
OpenGL: renderer: AMD Radeon Vega 10 Graphics (RAVEN DRM 3.42.0
5.15.18-200.fc35.x86_64 LLVM 13.0.0)
v: 4.6 Mesa 21.3.5 direct render: Yes
Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 01:00.1 chip-ID: 10de:10fa
Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus-ID: 05:00.6 chip-ID: 1022:15e3
Sound Server-1: ALSA v: k5.15.18-200.fc35.x86_64 running: yes
Sound Server-2: PipeWire v: 0.3.44 running: yes
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel port: e000 bus-ID: 02:00.0
chip-ID: 10ec:8168
IF: enp2s0 state: down mac:
Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
vendor: AzureWave driver: rtw_8821ce v: N/A port: d000 bus-ID: 04:00.0
chip-ID: 10ec:c821
IF: wlp4s0 state: up mac:
Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8
bus-ID: 1-4:2 chip-ID: 13d3:3530
Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Local Storage: total: 476.94 GiB used: 13.1 GiB (2.7%)
ID-1: /dev/nvme0n1 vendor: Micron model: 2200V MTFDHBA512TCK
size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 serial: temp: 38.9 C
ID-1: / size: 97.66 GiB used: 13.07 GiB (13.4%) fs: btrfs
dev: /dev/nvme0n1p6
ID-2: /boot/efi size: 96 MiB used: 38.7 MiB (40.3%) fs: vfat
dev: /dev/nvme0n1p1
ID-3: /home size: 97.66 GiB used: 13.07 GiB (13.4%) fs: btrfs
dev: /dev/nvme0n1p6
ID-1: swap-1 type: zram size: 8 GiB used: 768 KiB (0.0%) priority: 100
dev: /dev/zram0
System Temperatures: cpu: 66.0 C mobo: N/A gpu: amdgpu temp: 65.0 C
Fan Speeds (RPM): cpu: 4400
Processes: 331 Uptime: 44m Memory: 13.64 GiB used: 2.78 GiB (20.4%)
Init: systemd v: 249 runlevel: 5 target: graphical.target Compilers:
gcc: 11.2.1 Packages: N/A note: see --pkg Shell: Bash v: 5.1.8
running-in: gnome-terminal inxi: 3.3.11

dnf repolist says:
repo id repo name
fedora Fedora 35 - x86_64
fedora-cisco-openh264 Fedora 35 openh264 (From Cisco) - x86_64
fedora-modular Fedora Modular 35 - x86_64
google-chrome google-chrome
phracek-PyCharm Copr repo for PyCharm owned by phracek
rpmfusion-nonfree-nvidia-driver RPM Fusion for Fedora 35 - Nonfree - NVIDIA Driver
rpmfusion-nonfree-steam RPM Fusion for Fedora 35 - Nonfree - Steam
updates Fedora 35 - x86_64 - Updates