No X Server settings in nvidia-settings

I installed NVIDIA drivers (470xx drivers following Howto/NVIDIA - RPM Fusion) but when I open nvidia-settings pretty sure it should look something like this:

Instead, it only has “GPU 0 - (GeForce 920M)”, “Application Profiles” and “nvidia-settings Configuration”. Also, when I run games from Steam and have MangoHUD it only shows CPU load, no GPU, so pretty sure games do not actually use my GPU…

I’m pretty new to this, does anyone know what to do?

Please post the output of inxi -Fzxx as well as dnf list installed '*nvidia*'

I believe that GPU is new enough that it is supported by the latest drivers, since only the kepler chipsets were dropped when the 495 drivers were released. Support can be verified once the above info is available.

Is there a specific reason you chose the 470 driver instead of the newer ones?

Just a bit of searching on the web site shows that the 930M card uses the newer drivers but the 920M seems limited to the 470 drivers. Guess you probably have the proper driver but we need to verify that.

Sorry for late reply.

The output of inxi -Fzxx:

fish: Unknown command: inxi

The output of dnf list installed '*nvidia*':

Installed Packages
akmod-nvidia-470xx.x86_64                                            3:470.182.03-1.fc38                      @rpmfusion-nonfree
kmod-nvidia-470xx-6.2.14-300.fc38.x86_64.x86_64                      3:470.182.03-1.fc38                      @@commandline     
nvidia-gpu-firmware.noarch                                           20230404-149.fc38                        @updates          
nvidia-persistenced.x86_64                                           3:530.41.03-1.fc38                       @rpmfusion-nonfree
nvidia-settings-470xx.x86_64                                         3:470.182.03-1.fc38                      @rpmfusion-nonfree
nvidia-vaapi-driver.x86_64                                           0.0.9-1.fc38                             @rpmfusion-nonfree
xorg-x11-drv-nvidia-470xx.x86_64                                     3:470.182.03-1.fc38                      @rpmfusion-nonfree
xorg-x11-drv-nvidia-470xx-cuda.x86_64                                3:470.182.03-1.fc38                      @rpmfusion-nonfree
xorg-x11-drv-nvidia-470xx-cuda-libs.x86_64                           3:470.182.03-1.fc38                      @rpmfusion-nonfree
xorg-x11-drv-nvidia-470xx-kmodsrc.x86_64                             3:470.182.03-1.fc38                      @rpmfusion-nonfree
xorg-x11-drv-nvidia-470xx-libs.x86_64                                3:470.182.03-1.fc38                      @rpmfusion-nonfree

I chose 470 driver because in the RPM Fusion Howto page they said to check which one you should use on this website: Appendix A. Supported NVIDIA GPU Products

nvidia-settings does not properly support Wayland yet.

470.xx drivers are correct for your 920 M.

Probably should have mention that, but yes, I run under X11, it defaulted from Wayland to it automatically when I installed the drivers.

Yes, that should have happened. The drivers 470xx and earlier did not support wayland so x11 was the only option.

I suspect what you are seeing is the differences in the nvidia-settings app versions as well as the GPU itself. The one in your image above is using a newer GPU (940M) that is supported by the newer drivers and one is not. The chipset on the GPU is different so not all the same features are available.

Since the 470xx drivers are no longer receiving full support from nvidia the tools are not being updated the same and few enhancements can be expected.

Well, I guess that makes sense. But I’m still left with one question, why do games not use GPU? I even suspect that all the other applications don’t use it as well. I tried adding DRI_PRIME=1 into Steam’s environment variables using Flatseal and for the game individually in the properties and also tried launching Steam using Right-click → “Launch using Discrete Graphics Card”, but it didn’t help either. What am I missing?

I noticed that MangoHUD actually shows GPU load, but it is always 0% and disappears shortly after

What I do is follow the instructions here and the nvidia gpu is always used for evrey monitor in use.

Note that editing that file as suggested causes the system to always (and only) use the dGPU, while putting it in place without editing makes the system able to use the dGPU on the laptop screen for specified programs at users discretion (with the right click option you mentioned). Without the nvidia.conf file in place many laptops are unable to use the dGPU to drive the built-in screen.

1 Like

Adding Option "PrimaryGPU" "yes" solved both issues for me. Thank you!