No sound | Fedora 40 | Pipewire

I have no sound right now. Kernel 6.9.6-200. I think that the issue is with the kernel. I lost sound when I upgraded to fedora 40, but it got resolved with a kernel upgrade. However with kernel 6.9 it is not getting resolved. I think that the driver is not included with this version of the kernel and is frequently getting dropped with upgrades.

The sound card is

Communication controller: Intel Corporation 200 Series PCH CSME HECI #1

Sound services:

systemctl --user status pipewire-pulse pipewire wireplumber
Γ— pipewire-pulse.service - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.service; disabled; preset: disabled)
    Drop-In: /usr/lib/systemd/user/service.d
     Active: failed (Result: exit-code) since Mon 2024-07-01 10:50:52 IST; 23h ago
   Duration: 7ms
TriggeredBy: Γ— pipewire-pulse.socket
   Main PID: 1763 (code=exited, status=254)
        CPU: 7ms

Jul 01 10:50:52 brain systemd[1258]: pipewire-pulse.service: Scheduled restart job, restart counter is at 5.
Jul 01 10:50:52 brain systemd[1258]: pipewire-pulse.service: Start request repeated too quickly.
Jul 01 10:50:52 brain systemd[1258]: pipewire-pulse.service: Failed with result 'exit-code'.
Jul 01 10:50:52 brain systemd[1258]: Failed to start pipewire-pulse.service - PipeWire PulseAudio.

● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; enabled; preset: disabled)
    Drop-In: /usr/lib/systemd/user/service.d
     Active: active (running) since Mon 2024-07-01 10:50:50 IST; 23h ago
TriggeredBy: ● pipewire.socket
   Main PID: 1734 (pipewire)
      Tasks: 3 (limit: 9310)
     Memory: 1.5M (peak: 1.9M)
        CPU: 20ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─1734 /usr/bin/pipewire

Jul 01 10:50:50 brain systemd[1258]: Stopping pipewire.service - PipeWire Multimedia Service...
Jul 01 10:50:50 brain systemd[1258]: Stopped pipewire.service - PipeWire Multimedia Service.
Jul 01 10:50:50 brain systemd[1258]: Started pipewire.service - PipeWire Multimedia Service.

● wireplumber.service - Multimedia Service Session Manager
     Loaded: loaded (/usr/lib/systemd/user/wireplumber.service; enabled; preset: enabled)
    Drop-In: /usr/lib/systemd/user/service.d
     Active: active (running) since Mon 2024-07-01 10:50:50 IST; 23h ago
   Main PID: 1735 (wireplumber)
      Tasks: 6 (limit: 9310)
     Memory: 3.2M (peak: 3.7M)
        CPU: 54ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/wireplumber.service
             └─1735 /usr/bin/wireplumber

Welcome to :fedora:

Please use </> preformatted text when pasting commands or terminal output so we can more easily help.


Have you tried to restart or enable this service ?

1 Like

Thank you for the mail. I have now enabled pipewire-pulse. I checked it is running fine.
Still no sound
aplay -l says no soundcard installed.
wpctl status shows dummy output in sinks. The driver for this card is missing.
The card is
Audio device: Intel Corporation 200 Series PCH HD Audio

1 Like

Could you please provide the output of: inxi -Fzxx here for us to see. Please use preformatted text </>

This is the output

Kernel: 6.9.6-200.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc v: 2.41-37.fc40
Console: pty pts/2 DM: LightDM Distro: Fedora Linux 40 (Server Edition)
Type: Desktop System: Dell product: OptiPlex 5050 v: N/A serial:  Chassis: type: 3
Mobo: Dell model: 0WWJRX v: A01 serial:  part-nu: 07A2 UEFI: Dell v: 1.27.0
date: 09/19/2023
Info: quad core model: Intel Core i5-7500 bits: 64 type: MCP arch: Kaby Lake rev: 9 cache:
L1: 256 KiB L2: 1024 KiB L3: 6 MiB
Speed (MHz): avg: 2100 high: 3400 min/max: 800/3800 cores: 1: 3400 2: 3400 3: 800 4: 800
bogomips: 27199
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel arch: Gen-9.5 ports:
active: none empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2, HDMI-A-3 bus-ID: 00:02.0
chip-ID: 8086:5912
Display: server: v: 1.20.14 compositor: xfwm4 driver: X: loaded: modesetting
unloaded: fbdev,vesa dri: iris gpu: i915 tty: 217x98
API: OpenGL Message: GL data unavailable in console for root.
Device-1: Intel 200 Series PCH HD Audio vendor: Dell driver: snd_hda_intel v: kernel
bus-ID: 00:1f.3 chip-ID: 8086:a2f0
API: ALSA v: k6.9.6-200.fc40.x86_64 status: kernel-api
Server-1: JACK v: 1.9.22 status: off
Server-2: PipeWire v: 1.0.7 status: active (process) with: 1: pipewire-pulse status: active
2: wireplumber status: active 3: pipewire-alsa type: plugin
Device-1: Intel Ethernet I219-V vendor: Dell driver: e1000e v: kernel port: N/A bus-ID: 00:1f.6
chip-ID: 8086:15d6
IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: 
Device-1: TP-Link TP-Jln+ UB500 Adapter driver: btusb v: 0.8 type: USB rev: 1.1 speed: 12 Mb/s
lanes: 1 bus-ID: 1-2:2 chip-ID: 2357:0604
Report: btmgmt ID: hci0 rfk-id: 0 state: up address:  bt-v: 5.1 lmp-v: 10
Local Storage: total: 931.51 GiB lvm-free: 4 MiB used: 137.78 GiB (14.8%)
ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-75WN4A0 size: 931.51 GiB
speed: 6.0 Gb/s serial:  temp: 38 C
ID-1: / size: 93.07 GiB used: 27.47 GiB (29.5%) fs: xfs dev: /dev/dm-0 mapped: fedora-root
ID-2: /boot size: 4.59 GiB used: 344.8 MiB (7.3%) fs: xfs dev: /dev/sda3
ID-3: /boot/efi size: 4.65 GiB used: 7.4 MiB (0.2%) fs: vfat dev: /dev/sda2
ID-4: /home size: 465.44 GiB used: 106.45 GiB (22.9%) fs: xfs dev: /dev/dm-3
mapped: fedora-home
ID-5: /var size: 9.25 GiB used: 3.51 GiB (38.0%) fs: xfs dev: /dev/dm-2 mapped: fedora-var
ID-1: swap-1 type: partition size: 7.45 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/dm-1
mapped: fedora-swap
ID-2: swap-2 type: zram size: 7.61 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
System Temperatures: cpu: 31.0 C mobo: N/A
Fan Speeds (rpm): N/A
Memory: total: 8 GiB available: 7.62 GiB used: 1.96 GiB (25.7%) igpu: 32 MiB
Processes: 280 Power: uptime: 1d 21h 12m wakeups: 0 Init: systemd v: 255 target: graphical (5)
default: graphical
Packages: Compilers: clang: 18.1.6 gcc: 14.1.1 Shell: Sudo v: 1.9.15p5 running-in: pty pts/2
inxi: 3.3.34