No internet Access with connected WiFi

Hello, everyone!
Several days ago i had decided to migrate to fedora from another distro. In fresh install, everything was working fantastic! But the next day, I noticed that wifi doesn’t work. It indicate as connected, but no access to internet. I’ve done some research and tried several fixes, but nothing helps…
My suspicion is guilty of proprietary drivers, because it was the last action I’ve done with the system before finding wifi issues

  • I can’t ping the gateway
  • cable internet works fine
  • it is not a hardware issue(100%)
  • secure boot disabled
  • if I connect cable and use the internet for some time, and then unplug the cable, then wifi starts working ( only wifi, which is in the same network that cable is )
  • different networks don’t work too (I’ve tried to share wifi from my phone)
    Little information about:
inxi -i             
Network:
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
    driver: rtw_8822ce
  IF: wlo1 state: up mac: *my mac here*
  IP v4: 192.168.31.120/24 type: dynamic noprefixroute scope: global
  IP v6: fe80::b4:541a:94ff:39c5/64 type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: *my mac here*
  IP v4: 192.168.31.104/24 type: dynamic noprefixroute scope: global
  IP v6: fe80::38f2:9d0f:f1dd:3438/64 type: noprefixroute scope: link
  WAN IP: 194.44.45.157
ip route get 8.8.8.8
8.8.8.8 via 192.168.31.1 dev eno1 src 192.168.31.104 uid 1000 
    cache 
netstat -nr
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         192.168.31.1    0.0.0.0         UG        0 0          0 wlo1
192.168.31.0    0.0.0.0         255.255.255.0   U         0 0          0 wlo1

ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether  *my mac here* brd ff:ff:ff:ff:ff:ff
    altname enp4s0
3: wlo1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DORMANT group default qlen 1000
    link/ether  *my mac here* brd ff:ff:ff:ff:ff:ff
    altname wlp3s0

If you have both ethernet and wifi active on the same IP subnet you most likely will have issues. Use either wifi or ethernet but never both on the same subnet.

Your inxi output shows both active in the same subnet.

1 Like

As far as I’ve experienced, at least on Fedora, you can keep Ethernet and WiFi active and on the same subnet: each interface has a priority and the system is smart enough to use the Ethernet when connected. (But I could be wrong).

I would instead blame the WiFi card: RTL8822CE
Realtek WiFi chips are often problematic on Linux. Try to search this forum and you will get a lot of posts related to issues with RTL cards (also RTL8822CE).

1 Like

even in windows i have lots of issues in my old system. most brands in cheap system they cheapout on wifi which make a bad experience.

update your system and see if that solves if not try to load oldest kernel and see if with that works with your wifi.
and provide some extra info inxi -Fzx

As @alciregi said, trouble was related to a bad driver. I’ve just updated it with this manual.
Some tips for someone who will use this fix, don’t be scared if you won’t see /etc/modporbe.d/blacklist.conf file, if you haven’t just created it

2 Likes

I think this is true for “consumer” or “home” routers. I don’t have any problems using both wired and wireless active on a network using more expensive hardware intended than typical home gear.