Network fedora 35 to windows 7

im trying to network my fedora laptop to windows 7 for file sharing/printing etc. Mainly for my office use. i have smb installed and see windows network but it says folder empty.
on the windows machine i cant see the laptop.

ive also tried via bluetooth (using a dongle on the windows 7 machine) but the fedora laptop keeps disconnecting after a few seconds.

any advice appreciated


1 Like

In theory, mind you, as I’ve not done this in quite some time …
dnf -y install samba-client cifs-utils (you indicate you’ve already done this)
smbclient sharename -U username (sharename could be ‘\JohnWork\C$’ for example, and username is your username in the Windows environment authorized to access the share, perhaps John). You’ll be prompted to enter a password if needed. Use the smbclient to verify that you can see files in the share, using ls for example, then exit. Success at this point means you’ve authenticated and access works.
For longer periods, you’ll want to mount the share: mount -t cifs -o vers=3.0,username=John '\\JohnWork\C$' /mnt
See various documents for mounting drives and automatic mounts at boot, or I can walk you through the steps.
Again, I’ve not tried this recently so there may be something missing. If you have issues, please paste output here using the </> markup so that it is readable.
Good luck

john@UNKNOWN ~]$ smbclient johwork -U johnpc
Password for [SAMBA\johnpc]:

johwork: Not enough '\' characters in service
Usage: smbclient [-?EgqBNPkV] [-?|--help] [--usage] [-M|--message=HOST] [-I|--ip-address=IP] [-E|--stderr] [-L|--list=HOST]
        [-T|--tar=<c|x>IXFvgbNan] [-D|--directory=DIR] [-c|--command=STRING] [-b|--send-buffer=BYTES] [-t|--timeout=SECONDS]
        [-p|--port=PORT] [-g|--grepable] [-q|--quiet] [-B|--browse] [-d|--debuglevel=DEBUGLEVEL] [--debug-stdout]
        [-s|--configfile=CONFIGFILE] [--option=name=value] [-l|--log-basename=LOGFILEBASE] [--leak-report] [--leak-report-full]
        [-R|--name-resolve=NAME-RESOLVE-ORDER] [-O|--socket-options=SOCKETOPTIONS] [-m|--max-protocol=MAXPROTOCOL]
        [-n|--netbiosname=NETBIOSNAME] [--netbios-scope=SCOPE] [-W|--workgroup=WORKGROUP] [--realm=REALM]
        [-U|--user=[DOMAIN/]USERNAME[%PASSWORD]] [-N|--no-pass] [--password=STRING] [--pw-nt-hash]
        [-A|--authentication-file=FILE] [-P|--machine-pass] [--simple-bind-dn=DN] [--use-kerberos=desired|required|off]
        [--use-krb5-ccache=CCACHE] [--use-winbind-ccache] [--client-protection=sign|encrypt|off] [-k|--kerberos] [-V|--version]
        [OPTIONS] service <password>
[john@UNKNOWN ~]$ 

Yeah, that won’t work. The SMB path will look like \\servername\sharename, two leading backslashes, server name, another backslash, sharename. And on the shell command line, that path will likely need to be enclosed in single quotes. If you have a Windows system available on the network, you can look at the properties of the share using the Windows Explorer. If you’re trying to access your own data on your work Windows system, you’ll have to “share” it from there, then you can look at the properties of your share. If the share is instead mounted on a Windows system with a drive letter, the drive letter properties will show the share name you need to use. In my home network I have an SMB server named worksys and a shared directory work, so the SMB path is \\worksys\work.

1 Like