Multiple issues with Thunderbolt 3 port

I got a new laptop back in January and for the last couple of months, I have not been able to get the TB3 port working correctly (there is only one, and it’s not used for charging). I want to remember that it did work fine for the first few weeks until some kernel update, but I can’t say for sure. The laptop in question is a Razer Blade 15 (RTX 2060 model).

This is some behaviors I am currently seeing:

  • No matter if I have User or No Security in BIOS, the port seems to fall back to being just a DisplayPort (e.g. I can get a picture from my dock but no USB or other connectivity)
  • boltctl list yields nothing no matter the security config mentioned above
  • dmesg shows this message: “thunderbolt 0000:06:00.0: failed to read root switch config space, giving up” after boot
  • Port dies after suspending the computer (e.g. when I wake the computer back up again the port doesn’t work, until I fully reboot the computer again)
    • And the computer somehow still thinks that any monitor that was plugged-in still exists, so if I was using an external monitor before as the only monitor, I am left with a black screen on the laptop and no ability to do anything except a REISUB or power cycle
  • Sometimes, if I have something plugged-in to the port on boot, the computer just fails to boot (gets stuck on a black screen).

I am currently on Fedora 31 with kernel 5.5.8-200.fc31.x86_64. I tried googling the dmesg error above but couldn’t find anything useful. I am tempted to try an older kernel but I can’t remember which version I originally had (maybe 5.2?).

1 Like

   Hi.  About the blank screen: if you press Alt Ctrl F4, then Alt Ctrl Del, do reboot happens (as alternative to REISUB)?
   You can test if this device worked well with the older Kernels by booting in an Live medium session.

Hi, thanks for the advice! I have actually never been able to switch TTY on this laptop either. Nothing ever happens when I try Ctrl Alt F. So yeah unfortunately the above did not do anything. Fortunately I still have the live USB from when I first installed Fedora so I’m gonna try to boot into it to see which kernel version it comes with and then try to install that kernel version in my main boot and see if things work better.

EDIT: Correction: TTY switching does seem to work now. Either I only tried it in situations where it hasn’t worked or it got fixed in newer kernels. Oh well, at least I wasn’t able to switch during the black-screen “freezes” (or whatever is going on).

   The laptop possible has some Function keys interpretation settings in the BIOS (“firmware setup”).  Mine by default interpreted a F3 key as “toggle WiFi”, and a Fn + F3 combination as an actual F3.

In my case the F buttons are the default (thankfully), but yeah I’ve just been having weird issues I guess where switching TTY is not an option.