Microphone stops working after resuming from suspend

Have a strange issue (been having since installing Fedora 37, so nothing new) where my microphone input goes haywire after resuming from suspend.

I’m using an audio interface, and the current way of fixing it is to restart the interface, after which it resumes working fine.

Probably the strangest thing about this issue is that the microphone input that normally just has my microphone is actually routing the system audio to it. So if I have a YouTube video playing, the audio of that youtube video (at a low volume) is what comes out of the microphone input I normally use. If I restart the interface, then it goes back to normal.

Anyone got any ideas?

Take a look at:
wpctl status
with it working and not working


1 Like

Thanks for the help, here’s the one that does not work, and here’s the one after restarting that works.

Does it do the same thing on a new user?

Are you restarting wireplumber or pipewire to reset the interface or doing something else?


1 Like

Sorry for the late reply! Just tried it on a new user and the same issue is there. Switching users after it goes out also doesn’t restore it to a functioning state.

To restart the interface, I’m powering it off on the actual device itself (it has an on/off switch) and turning it back on.

So you may want to run through the same sequence with lsmod (working and not working)

Once you are in a non-working state and know what the driver is:
sudo rmmod “driver name”
sudo modprobe “driver name”

If the driver is not present after suspend just do the modprobe to load it.

You may need to run a script that does this when you resume from suspend.


I tried doing the same thing with lsmod and the lists are identical (put it through a diff checker just in case)… Any other ideas?