Memory test

Five minutes after booting and opening Chrome (stable) system froze and rebooted it self…
I checked dmesg and got this beauty:

memtest86+ isn’t compatible with UEFI systems

CONFIG_MEMTEST in kernel isn’t enabled. You could add memtest in kernel command line and have the kernel self-check your memory.

I ran Prime95 (Blend test) for 2 hours with no errors.
I am going to use stressapptest from Google to run a memory test as well.
Any other ideas/suggestions?

What CPU and MB do you have?

Ryzen 5 3600
Kernel 5.10.23-200.fc33.x86_64

I do not think that kernel is to blame but is a hardware problem.
Try with default BIOS settings and XMP 2 (if you use XMP).

BIOS are at default settings since day 1.
RAM is with XMP 1 since day 1.

The memory test (GitHub - stressapptest/stressapptest: Stressful Application Test - userspace memory and IO test) that I ran in addition to Prime95 reported no errors.

From the links that you posted it looks related to the CPU.

If it does it again, I will RMA the CPU.

I do not think that the CPU, PSU or RAM are to blame but BIOS.
For me it work with Agesa (and you have it) and XMP 2.
If it will not work for you try with Agesa