Low CPU frequency, CPU not hot. Help needed to to enable "cpu-idle-cooling" instead of "acpi_cpufreq"

I have a new laptop with a A4-9210e CPU/APU. It doesn’t get hot (I’ve checked the temps) but it always goes down to 800MHz after a small time loading web pages or watching videos (then browsing and watching slows to a crawl), it’s meant to have a base rate of 1500MHz and a turbo of 22000MHz. I’ve tried everything possible in regards to changing acpi_cpufreq options, minimum frequency, performance governor etc. Many hours. Nothing makes a difference, I think the frequency settings are locked by the BIOS/UEFI and there are no options in the BIOS/UEFI it’s self to stop that. Before I give up and buy a new laptop I wanted to try the new “cpu-idle-cooling” driver that was released with the 5.6 kernel.


I have the 5.6.2 kernel installed but I can’t find any cpu-idle-cooling modules in cat /proc/modules.

If I run cat /proc/modules | grep cpu the only output is:

acpi_cpufreq 28672 0 - Live 0xffffffffc0922000

Can anyone help?

Reading this documentation I doubt the cpu-idle driver will do any good in your situation. If I understand correclty it injects idle cycles when your chip has reached a critical temperature.

I would say your issue is elsewhere…

If the acpi_cpufreq is being overly cautious or broken wouldn’t this be a good alternative? Instead of down-clocking it will stay at a high frequency and insert idle cycles when near a high temperature. If it works as advertised and my BIOS/UEFI allows it to work properly isn’t this a good option?

You want to run at performance at all times and only use the cou-idling if temperature rises? It could work, but if it was my machine I wouldn’t be happy because you are potentially running too hot on average (causing the fan to make noise), and battery won’t last long.

I changed the frequency governor to performance. Nothing I did with the cpu freq driver had any effect (including minimum frequency settings, other governors etc.), it all looked like it was working too in regards to /proc/cpuinfo and cpu info programs. When I run cpuid it says read-only effective frequency interface = true , I think my BIOS/UEFI blocks any frequency manipulation.

# Hi;  are you sure it's acpi_cpufreq?
cat /sys/devices/system/cpu/cpufreq/policy*/scaling_driver
1 Like

Yup certain it says acpi_cpufreq there and in various hardware / cpu info programs.