Kernel panic after upgrade to 37.20230315.0

I am on F37 Workstation, Just updated to the 6.2.9 kernel and first boot I got a kernel panic.
I did a forced power off then back on and it booted properly.
Have you tried a second boot after the kernel panic halt?

I tried it; alas, no joy.

For those who cannot wait you can download the 6.2.11 kernel files from here for Fedora 37. See command below for a list of files to download, working on my Ryzen 1500x.

Then run the following from the download folder

sudo rpm -i ./kernel-6.2.11-200.fc37.x86_64.rpm ./kernel-core-6.2.11-200.fc37.x86_64.rpm ./kernel-modules-6.2.11-200.fc37.x86_64.rpm ./kernel-devel-6.2.11-200.fc37.x86_64.rpm ./kernel-modules-core-6.2.11-200.fc37.x86_64.rpm 

Nice work, Lenard.

Do you know if this will work for Fedora Silverblue?

And, just for the record (again):

Kernel panics in the 37.20230414 update.

The only way I know to do this on Silverblue is to rebase to the testing branch which has the 6.2.11 kernel. It worked when I tested it in a VM, not sure what the stability would be like.

rpm-ostree rebase fedora/37/x86_64/testing/silverblue

Kernel booted! in the 37.20230601.0 update.

Kernel (per uname -a) is 6.3.4-101.fc37.x86_64