Kernel driver not installed (rc=-1908)

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver is either not loaded or not set up correctly. Please try setting it up again by executing


as root.

If your system has EFI Secure Boot enabled you may also need to sign the kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load them. Please see your Linux system’s documentation for more information.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

Welcome to ask.:fedora:edora @johnestt

Could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

1 Like

The message tells you that it is possible secure boot is causing the problem. To verify that is the cause you might try disabling secure boot in the bios and see if you can then get virtual box to load properly.



Kernel: 5.16.9-200.fc35.x86_64 x86_64 bits: 64 compiler: gcc
v: 2.37-10.fc35 Desktop: GNOME 41.4 Distro: Fedora release 35 (Thirty Five)
Type: Laptop System: Dell product: Latitude E6520 v: 01
Mobo: Dell model: 0NVF5K v: A00 serial: BIOS: Dell
v: A07 date: 09/15/2011
ID-1: BAT0 charge: 14.9 Wh (100.0%) condition: 14.9/66.6 Wh (22.4%)
volts: 12.7 min: 11.1 model: SMP DELL HTX4D2A status: Full
Info: dual core model: Intel Core i7-2620M bits: 64 type: MT MCP
arch: Sandy Bridge rev: 7 cache: L1: 128 KiB L2: 512 KiB L3: 4 MiB
Speed (MHz): avg: 829 high: 924 min/max: 800/3400 cores: 1: 924 2: 798
3: 798 4: 798 bogomips: 21550
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0
Display: wayland server: X.Org compositor: gnome-shell driver:
loaded: i915 note: n/a (using device driver) - try sudo/root
resolution: 1366x768~60Hz
OpenGL: renderer: Mesa Intel HD Graphics 3000 (SNB GT2)
v: 3.3 Mesa 21.3.6 direct render: Yes
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
Sound Server-1: ALSA v: k5.16.9-200.fc35.x86_64 running: yes
Sound Server-2: PipeWire v: 0.3.47 running: yes
Device-1: Intel 82579LM Gigabit Network vendor: Dell driver: e1000e
v: kernel port: 4080 bus-ID: 00:19.0
IF: enp0s25 state: down mac:
Device-2: Intel Centrino Advanced-N 6235 driver: iwlwifi v: kernel
bus-ID: 02:00.0
IF: wlp2s0 state: up mac:
IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Device-1: Intel Centrino Bluetooth Wireless Transceiver type: USB
driver: btusb v: 0.8 bus-ID: 2-1.5:5
Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: see --recommends
Local Storage: total: 223.57 GiB used: 25.78 GiB (11.5%)
ID-1: /dev/sda type: USB vendor: Crucial model: CT240BX500SSD1
size: 223.57 GiB
ID-1: / size: 222.55 GiB used: 25.54 GiB (11.5%) fs: btrfs dev: /dev/dm-0
mapped: luks-c1143dca-b4f5-4ee5-8c0f-4c5c9868af20
ID-2: /boot size: 973.4 MiB used: 239.7 MiB (24.6%) fs: ext4
dev: /dev/sda1
ID-3: /home size: 222.55 GiB used: 25.54 GiB (11.5%) fs: btrfs
dev: /dev/dm-0 mapped: luks-c1143dca-b4f5-4ee5-8c0f-4c5c9868af20
ID-1: swap-1 type: zram size: 7.63 GiB used: 0 KiB (0.0%) dev: /dev/zram0
System Temperatures: cpu: 56.0 C mobo: 22.0 C sodimm: SODIMM C
Fan Speeds (RPM): cpu: 0
Processes: 718 Uptime: 28m Memory: 7.63 GiB used: 3.9 GiB (51.1%)
Init: systemd runlevel: 5 Compilers: gcc: 11.2.1 Packages: N/A
note: see --pkg Shell: Bash v: 5.1.8 inxi: 3.3.12


This is probably too late, but I found this topic after encountering the same error in VirtualBox and wanted to share the solution.

I don’t use EFI secure boot. I found a solution here: VirtualBox - Error in SuplibOsinit - Kernel driver not installed (rc=-1908)

I ran these 2 commands in the terminal:

sudo dnf install make time perl gcc dkms kernel-devel kernel-headers

After rebooting the error was gone and I’m now installing an OS in VirtualBox.


Thank you so much Kevin, with secure boot disabled and these commands, virtualbox worked just fine. Much appreciated it.

still does not work!!! is there any other solution?

My secure boot was already off, tried these. Worked. Thanks.