Kernel 6.9.5-200.fc40.x86_64 fails to boot

I’m using Fedora 40 + KDE + Wayland + AMD 7950X CPU + Nvidia 4090 + LUKS. The new Kernel 6.9.5-200.fc40.x86_64 fails to boot. It does not show the LUKS password screen, and typing the password does not get me past the blank screen as well (Some time ago, with a previous Fedora version, I had a problem were the screen was blank but typing the password would work).

My previous kernel 6.9.4-200.fc40.x86_64 is booting properly, so I’m not under any urgent situation, but how can I know what’s wrong and try to fix?

Here is my grub config:

  GNU nano 7.2                                                                                                                                                                      /etc/default/grub                                                                                                                                                                                 
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau resume=UUID=<something> rd.luks.uuid=luks-<something> rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau"

Here is the result of inxi -Fzxx:

  Kernel: 6.9.4-200.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.41-37.fc40
  Desktop: KDE Plasma v: 6.1.0 tk: Qt v: N/A wm: kwin_wayland dm: SDDM
    Distro: Fedora Linux 40 (KDE Plasma)
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: ROG STRIX X670E-E GAMING WIFI v: Rev 1.xx
    serial: <superuser required> part-nu: SKU UEFI: American Megatrends v: 1905
    date: 02/05/2024
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard ERGO K860
    serial: <filter> charge: 100% (should be ignored) status: discharging
  Device-2: hidpp_battery_1 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 55% (should be ignored) status: discharging
  Info: 16-core model: AMD Ryzen 9 7950X bits: 64 type: MT MCP arch: Zen 4
    rev: 2 cache: L1: 1024 KiB L2: 16 MiB L3: 64 MiB
  Speed (MHz): avg: 901 high: 3777 min/max: 400/5881 cores: 1: 400 2: 3777
    3: 400 4: 400 5: 400 6: 400 7: 3599 8: 400 9: 3434 10: 400 11: 400 12: 400
    13: 400 14: 400 15: 400 16: 400 17: 400 18: 400 19: 400 20: 400 21: 400
    22: 400 23: 400 24: 400 25: 400 26: 400 27: 400 28: 400 29: 3628 30: 400
    31: 400 32: 3599 bogomips: 287994
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA AD102 [GeForce RTX 4090] vendor: Gigabyte driver: nvidia
    v: 550.90.07 arch: Lovelace pcie: speed: 2.5 GT/s lanes: 16 ports:
    active: none off: DP-2,DP-3,HDMI-A-2 empty: DP-4 bus-ID: 01:00.0
    chip-ID: 10de:2684
  Device-2: AMD Raphael vendor: ASUSTeK driver: amdgpu v: kernel
    arch: RDNA-2 pcie: speed: 16 GT/s lanes: 16 ports: active: none
    empty: DP-1,HDMI-A-1,Writeback-1 bus-ID: 12:00.0 chip-ID: 1002:164e
    temp: 47.0 C
  Device-3: Logitech Logitech Webcam C925e driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 1-5:3 chip-ID: 046d:085b
  Display: wayland server: v: 1.20.14 with: Xwayland v: 24.1.0
    compositor: kwin_wayland driver: N/A d-rect: 4752x2330 display-ID: 0
  Monitor-1: DP-2 pos: top-right res: 1680x1050 size: N/A
  Monitor-2: DP-3 pos: bottom-l res: 3072x1280 size: N/A
  API: EGL v: 1.5 platforms: device: 0 drv: nvidia device: 1 drv: radeonsi
    device: 3 drv: swrast surfaceless: drv: nvidia wayland: drv: nvidia x11:
    drv: zink inactive: gbm,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.90.07
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 4090/PCIe/SSE2
    display-ID: :0.0
  API: Vulkan v: 1.3.283 surfaces: xcb,xlib,wayland device: 0
    type: discrete-gpu driver: N/A device-ID: 10de:2684 device: 1
    type: integrated-gpu driver: N/A device-ID: 1002:164e device: 2 type: cpu
    driver: N/A device-ID: 10005:0000
  Device-1: NVIDIA AD102 High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: speed: 16 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:22ba
  Device-2: AMD Rembrandt Radeon High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: speed: 16 GT/s lanes: 16
    bus-ID: 12:00.1 chip-ID: 1002:1640
  Device-3: Logitech Logitech Webcam C925e driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 1-5:3 chip-ID: 046d:085b
  Device-4: Audient EVO4 driver: snd-usb-audio type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 3-5.1.1:10 chip-ID: 2708:0006
  Device-5: Shure MV5 driver: hid-generic,snd-usb-audio,usbhid type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 bus-ID: 3-5.1.3:11 chip-ID: 14ed:1000
  Device-6: ASUSTek USB Audio driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 3-6:4 chip-ID: 0b05:1a52
  API: ALSA v: k6.9.4-200.fc40.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
  Device-1: Intel Wi-Fi 6E AX210/AX1675 2x2 [Typhoon Peak] driver: iwlwifi
    v: kernel pcie: speed: 5 GT/s lanes: 1 bus-ID: 09:00.0 chip-ID: 8086:2725
  IF: wlp9s0 state: down mac: <filter>
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB
    rev: 2.1 speed: 480 Mb/s lanes: 1 bus-ID: 3-5.4.1:7 chip-ID: 0bda:8153
  IF: enp16s0u5u4u1 state: down mac: <filter>
  Device-3: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB
    rev: 2.1 speed: 480 Mb/s lanes: 1 bus-ID: 3-5.4.2:8 chip-ID: 0bda:8153
  IF: enp16s0u5u4u2 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
  Device-1: Intel AX210 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 1-9:4 chip-ID: 8087:0032
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.3
    lmp-v: 12
  Local Storage: total: 4.78 TiB used: 677.06 GiB (13.8%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WD BLACK SN850X 1000GB
    size: 931.51 GiB speed: 63.2 Gb/s lanes: 4 serial: <filter> temp: 47.9 C
  ID-2: /dev/nvme1n1 vendor: Western Digital model: WD BLACK SN850X 1000GB
    size: 931.51 GiB speed: 63.2 Gb/s lanes: 4 serial: <filter> temp: 43.9 C
  ID-3: /dev/sda vendor: Hitachi model: HUA723030ALA640 size: 2.73 TiB
    speed: 6.0 Gb/s serial: <filter>
  ID-4: /dev/sdb vendor: Generic model: USB3.0 CRW -SD size: 238.3 GiB
    type: USB rev: 3.0 spd: 5 Gb/s lanes: 1 serial: <filter>
  ID-1: / size: 399.98 GiB used: 343.48 GiB (85.9%) fs: btrfs dev: /dev/dm-0
    mapped: luks-ce42ef51-0cb3-41a1-bbdf-baf289274a95
  ID-2: /boot size: 4.84 GiB used: 506 MiB (10.2%) fs: ext4
    dev: /dev/nvme0n1p1
  ID-3: /boot/efi size: 4.99 GiB used: 45.7 MiB (0.9%) fs: vfat
    dev: /dev/nvme0n1p2
  ID-1: swap-1 type: partition size: 48 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p4
  ID-2: swap-2 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 52.2 C mobo: N/A gpu: amdgpu temp: 48.0 C
  Fan Speeds (rpm): N/A
  Memory: total: 32 GiB note: est. available: 30.55 GiB used: 9.35 GiB (30.6%)
  Processes: 691 Power: uptime: 29m wakeups: 0 Init: systemd v: 255
    target: graphical (5) default: graphical
  Packages: pm: flatpak pkgs: 25 Compilers: clang: 18.1.6 gcc: 14.1.1
    Shell: Zsh v: 5.9 running-in: terminator inxi: 3.3.34

I currently have not the time to pick up another case. But if you want, you can try if your issue maybe is already solved in 6.9.6:
FEDORA-2024-aca908f73b — bugfix update for kernel — Fedora Updates System

sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2024-aca908f73b (this command will get 6.9.6 and its dependencies from testing but it will NOT enable the testing repo in general, so this is a one time action)

If that solves your issue, feel free to let us know here. If not, let us know anyway so that it is clear that this is not a one-kernel-only issue…

(also, be more careful with what tags you add: the more precise your tagging is, the better are the chances to get help; inappropriate tags can mislead)


Removed audio, bluetooth, intel

Added kernel and removed kde

Added encryption, luks2

Removed flatpak

Are you maybe missing initramfs in “/boot”. If so, see

@ptrck4193 Thank you.
I have these in /boot:


@py0xc3 Thank you.
The Kernel 6.9.6 does the same exact behaviour.
I also disconnected all non-essential peripherals, but nothing changed.

Two questions:

  1. How can I make sure the Nvidia Kernel module is successfully compiled for the newly installed kernels? (I know the build process kicks off in the background)
  2. How can I see any boot errors that happened before unlocking LUKS?
  1. Wait at least 5 minutes before rebooting to allow time for the build of the new modules.

  2. replace the modules with:
    a. sudo dnf remove kmod-nvidia-6.9.5-200.fc40.x86_64 would remove the modules for the 6.9.5 kernel. You can select the one for the currently running kernel using kmod-nvidia-$(uname -r)
    b. sudo akmods --force will rebuild the modules and reinstall the kmod-nvidia-N.N.N package or for the specific running kernel use sudo akmods --force --kernels $(uname -r)

Use man akmods or akmods --help to see exactly what it does and the options available.

There also was an issue where the command line contained the resume=UUID=.... option and it prevented the 6.9 kernel from booting. I do not suspect that for you since the 6.9.4 kernel does boot but it is possible.

The fix for that was to use sudo grubby --update-kernel=ALL --remove-args=resume=UUID=... using exactly what shows in the kernel command line with cat /etc/kernel/cmdline and it seemed to fix the problem for most. A resume statement in the kernel command line is usually not required unless the user is actually using hibernate.

@computersavvy Thank you.
When running the grubby command I get this: no action specified

sudo grubby --remove-args=resume=UUID=<the uuid in my command>

I did a search and did not find an answer

Sorry, I missed one part of that command. It has been fixed in the post above so please try it again.

@computersavvy Thank you.
This did not fix the problem though.

After I did sudo dnf remove kmod-nvidia-6.9.6-200.fc40.x86_64,
doing sudo akmods --force --kernels kernel-6.9.6-200.fc40.x86_64 shows this:

Could not find files needed to compile modules for kernel-6.9.6-200.fc40.x86_64
Are the development files for kernel kernel-6.9.6-200.fc40.x86_64 or the appropriate kernel-devel package installed?

Do I need to modify this command because the kernel was previously installed from upgrade-testing repo?

That error shows the kernel-devel package for 6.9.6 is not installed. Since that is a testing kernel the kernel-devel package should be in the same repo. Try installing it then repeat the akmods command.

Without the kernel-devel package the driver modules cannot be compiled for that kernel.

I just checked and it is there.

# dnf list kernel-devel --enablerepo updates-testing
Available Packages
kernel-devel.x86_64                                         6.9.6-200.fc40                                          updates-testing 

Install it with dnf install kernel-devel-6.9.6-200.fc40 kernel-devel-matched-6.9.6-200.fc40 --enablerepo updates-testing

Your problem kind of reminds me of the one I’m having. You might want to check out the workaround that mostly fixed it for me until the next kernel upgrade:

Basically, what you would need to do is disable plymouth in grub and run these commands:

sudo dnf remove ‘kmod-nvidia-*’
sudo akmods --force

1 Like

3 posts were split to a new topic: Problem booting with kernel 6.9.5

That is similar.
However, the OP is able to boot into an older kernel and can do the repairs from there.

In my case, just running these two commands didn’t fix the black screen. I also had to completely disable plymouth and make it permanent until a update fixes this.

sudo nano /etc/default/grub


nomodeset plymouth.enable=0 at the end of line that is beginning with GRUB_CMDLINE_LINUX=

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

and reboot

1 Like