Kernel 5.7.11 not enough space in /boot

Hi There – updates to my system required new kernel 5.7.11 and removing kernel 5.6.19. However I got an error from dnfdragora that my /boot filesystem needed an extra 38 MB of space to install 5.7.11. My /boot space is 2 GB big, and according to GParted I am only using 379 MB (for all 3 older kernel versions currently there) leaving 1.63 GB unused – so it seems there should be plenty of space to install the new kernel …?

Is there anything wrong with the file size details currently in the update packages for 5.7.11 as stated in dnfdragora ?

Do I really need to make my /boot partition larger than 2 GB ?


1 Like

Please, post the diagnostics output:

rpm -q kernel; df -h /boot; lsblk -o +FSTYPE,UUID | grep -e /boot
1 Like

Thanks for the reply “vgaetera”, sorry for the delay, away the last few days. Here is the output you asked for (2-disk RAID mirror) – shows I am only using 16% of my /boot partition.

[zook@Virago ~]$ rpm -q kernel; df -h /boot; lsblk -o +FSTYPE,UUID | grep -e /boot




Filesystem Size Used Avail Use% Mounted on

/dev/md126p1 2.0G 283M 1.6G 16% /boot

├─md126p1 259:0 0 2G 0 part /boot ext4 9826862d-de6a-408a-977a-46cebd37a9d8

├─md126p1 259:0 0 2G 0 part /boot ext4 9826862d-de6a-408a-977a-46cebd37a9d8
[zook@Virago ~]$

1 Like

…well, as it often happens, my machine is making me look like an idiot…

Just before posting this update, I figure I run dnfdragora and got a few more updates, including the new kernel that failed to update last time. It all went fine, and did not get any errors this time. Not sure why it has worked this time, and I swear, really, that last time it did tell me I needed more space… Oh, well, lesson learned, will try any updates in the future at leas twice, and spread apart a few days, before I post my troubles… :slight_smile:


1 Like

Fedora keeps no more than 3 kernels by default, which currently should take ~200 MB of /boot space.