KDE Plasma weirdness/freezing after upgrade to 39

So after upgrading from Fedora 38 to 39 on my desktop I am experiencing, pretty much, the exact same scenario as I posted here when I update to 38 last year:

This time around it seems it may be a rendering issue. Probably related to crappy NVIDIA crap again. The scenario I am seeing is that as soon as I login and open Firefox, the system crashes, freezes up. Sometimes I can ssh remotely to an active system while the Desktop Environment locally is frozen. Sometimes I can’t ssh remotely. At first I thought it may be a Firefox issue. I then tried moving from logging in with X11 (has been my default for years) to Weyland, but that didn’t solve the issue. I started opening Brave browser, because I thought it was Firefox, but even though it was working for a while, opening Brave in one scenario caused a freeze up of the system, even in Weyland. Which leads me to now thinking that it is a rendering of the desktop and not specific to a web browser. Even now as I type this from my working laptop with nothing open on my desktop but Konsole I am seeing Plasma error windows popping up in the notification tray.
Does anyone have any thoughts or suggestions on how to fix my unstable desktop?

I just ran the following command and it doesn’t even look as if NIVIDIA drivers are loaded:

[ed@edfed: ~]$ sudo lsmod | grep -i nvidia

[ed@edfed: ~]$

In fact, it looks like the system defaulted to nouveau, for some reason:

[ed@edfed: ~]$ sudo lsmod | grep -i nouveau
nouveau              3465216  55
drm_exec               12288  1 nouveau
gpu_sched              57344  1 nouveau
i2c_algo_bit           20480  1 nouveau
drm_ttm_helper         12288  1 nouveau
ttm                   110592  2 drm_ttm_helper,nouveau
drm_display_helper    229376  1 nouveau
mxm_wmi                12288  1 nouveau
video                  77824  2 asus_wmi,nouveau
wmi                    45056  5 video,asus_wmi,wmi_bmof,mxm_wmi,nouveau

Are there recommended steps on getting nvidia drivers loaded and running again?
Thanks in advance.

EDIT: Saw this:

[ed@edfed: ~]$ sudo dnf list installed '*nvidia*'
Installed Packages
akmod-nvidia.x86_64                                                      3:545.29.06-2.fc39                                 @rpmfusion-nonfree-updates
kmod-nvidia-6.6.13-100.fc38.x86_64.x86_64                                3:545.29.06-2.fc38                                 @@commandline             
kmod-nvidia-6.6.13-200.fc39.x86_64.x86_64                                3:545.29.06-2.fc39                                 @@commandline             
kmod-nvidia-6.6.9-100.fc38.x86_64.x86_64                                 3:545.29.06-2.fc38                                 @@commandline             
nvidia-gpu-firmware.noarch                                               20240115-2.fc39                                    @updates                  
nvidia-modprobe.x86_64                                                   3:545.29.06-1.fc39                                 @rpmfusion-nonfree-updates
nvidia-settings.x86_64                                                   3:545.29.06-1.fc39                                 @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                                               3:545.29.06-2.fc39                                 @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64                                     3:545.29.06-2.fc39                                 @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64                                       3:545.29.06-2.fc39                                 @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.i686                                            3:545.29.06-2.fc39                                 @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                                          3:545.29.06-2.fc39                                 @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-power.x86_64                                         3:545.29.06-2.fc39                                 @rpmfusion-nonfree-updates

So, I may have found the fix, time will tell.

sudo dnf remove *nvidia*

Reboot, and then reinstall with the following command:

sudo dnf install akmod-nvidia -y

Now I see this:

[ed@edfed: ~]$ sudo lsmod | grep -i nvidia
[sudo] password for ed: 
nvidia_drm            118784  10
nvidia_modeset       1585152  20 nvidia_drm
nvidia_uvm           3522560  0
nvidia              62394368  337 nvidia_uvm,nvidia_modeset
video                  77824  2 asus_wmi,nvidia_modeset

What is sometimes missed is that it takes time for the akmod system to build the nvidia drivers.

Also on an upgrade to f39 the drivers are often not rebuilt at all.

After a dnf update that installs a new kernel you need to wait for the drivers to be built.

You can see this is happening by checking systemctl list jobs and wait for any akmods job to complete.

It looks as if an uninstall and reinstall fixed the issue. Looking back at my own notes/KB here at home the same thing happened to me when I upgraded from 37 to 38. I guess I need to pay closer attention to my own notes. :grinning:

I’m looking forward to the day when I can afford a new system that will be all AMD, no more NVIDIA.

The dnf remove step may have been an error.

It also removes the firmware package nvidia-gpu-firmware which is required for proper operation of newer GPUs.

You did not indicate that you had reinstalled that package, so if dnf list installed \*nvidia\* does not show that package now, it probably should be reinstalled with sudo dnf install nvidia-gpu-firmware followed by a reboot.

In most cases the solution for the initial error is much simpler. It only requires 2 steps and a reboot.

  1. sudo dnf remove kmod-nvidia-*
  2. sudo akmods --force
  3. reboot

You stated that firmware is for newer GPUs. Mines old, a GTX 970.
But, I just looked on NVIDIA’s site and it looks as if my model is listed. So, I will install it.

@computersavvy So, I was going to make your response as a solution, but, unfortunately, I am still having issues. I installed the firmware, rebooted and the behavior is almost the same. Now when I log into Plasma (X11) almost a minute later my screen goes blank black. I tried completing the remove of the kmod-nvidia and akmods --force but it did not fix the issue. I rebooted, logged into Plasma (X11), and close to a minute later I have a blank black screen. I can still ssh to it remotely though, no freeze ups of the system.

EDIT UPDATE: After the above post I rebooted and tried logging into Plasma (Wayland). Same behavior, except it, somewhat, recovered by putting me at the login screen. I tried logging in Plasma (Wayland) again and it immediately took me to a blank black screen.

What i see is if i get a desktop from login in a few seconds plasma will stay running.

If it take 30 seconds to show a desktop then after 10 more seconds i will be throw back to the login screen. A reboot is needed to have another try.

There are logs from kwin reporting errors when it fails.
You can check using journalctl --user

It’s funny you should mention that. The next time I attempted to login, I switched it from Wayland to X11, ssh remotely, ran journalctl -f to watch the logs around the 1 minute mark after login and don’t you know the only time I am actually watching logs all is well. No blank black screen. I’m typing this post from my working desktop now.
Even though I am afraid to reboot my computer now, we’ll see what happens the next time I need to complete updates and reboot.

The firmware is for all GPUs. Newer firmware is required for newer GPUs, but the firmware for older GPUs remains.

It sometimes means I have to do an extra reboot every now and agaun, but its unusual to be 2 extra reboots.