KDE - kontact not starting with "error while loading shared libraries"


Hello all,

recently I ran into an error when trying to start kontact from yakuake. Since a couple of days typing kontact and hitting Enter results in:

kontact: symbol lookup error: /lib64/libQt5WebEngineCore.so.5: undefined symbol: _ZN3re23RE23Arg9parse_intEPKciPv

libQt5WebEngineCore.so.5 is a symlink to libQt5WebEngineCore.so.5.12.2 which is part of the package qt5-qtwebengine.

As per output from dnf history info qt5-qtwebengine the package was last updated from @updates on 27. May 2019 on my system; kontact also got updated with the same transaction and since it was running like a charm.

Has anyone a hint what could have happened respectively where to start troubleshooting?


Note 1: starting kontact from the application launcher doesn’t work as well
Note 2: running:

nm -D /lib64/libQt5WebEngineCore.so.5.12.2 | grep Arg9 -

results in:

U _ZN3re23RE23Arg9parse_intEPKciPv

looks like the symbol is really undefined. :slightly_frowning_face:

sudo rpm --verify --all kontact\* qt\*

There is an existing bug report about this already. There should be an update out soon to fix it AFAICT.


Thanks for your feedback, actually this did not show any output for me. Anyhow, I’ll keep rpm --verify in mind for future. :slight_smile:

OK, thanks for information. Looks like I ran into the same issue. Downgrading the re2-package (as suggested in the bug report) got my kontact up and running again. :+1:

1 Like