Issues with Fedora33 and up regarding mouse with doubleclick button where click is registered as one click instead of a doubleclick

Hello. I have a mouse with regular buttons and one additional button which is a doubleclick button.
When using older versions of Fedora (prior to 31), everything worked great. I have noticed the mouse button stopped doubleclicking after update from kernel 5.11 to 5.12 on F32 or F33 I think, I cannot remmember, but I doubt it has anything to do with kernel version, since Pop_OS! on the same mashine (dual-booting as a backup OS) works on kernel 5.13.
So, the issue is not hardware related, probably not kernel version related.
I am using Fedora 34 with Nvidia drivers and X11 on Gnome40 (default installation with Nvidia drivers added), it did not work on opensource drivers and wayland as well.

My Pop_OS! has also default installation of 21.04 with Nvidia drivers added, nothing else. They use older Gnome(3.38xx), X11. I use POP as a backup OS, Fedora is my primary.

I never do any custom mods to my linux install, just install my distro, install nvidia drivers and use it.

Anyone has any ideas what could be the problem with one distro registering button event as doubleclick and another (Fedora) not?

Thanks in advance,

Does your mouse have a mouse wheel? By default tapping the mouse wheel acts as double click.
Did you check the settings of your mouse? Maybe you just have to re-assign your special button to the doubleclick action.

Yes it does have a wheel. It’s A4tech X-710BK (gaming) mouse with left, right, wheel, doubleclick, back and forward buttons, all buttons work. Even DPI changing button works. The only button that does not work as expected is the orange doubleclick button, it works exactly like a regular left click. This button basically runs a script that when clicked executes two consecutive left clicks. I have tried it on Windows and Ubuntu based distros it works, but on Fedora it does not. No special configurations on Ubuntu based distros, nor on Windows. Wheel click opens for example folders in Files, but doubleclick button just selects the folder (like a single left click).

Does anyone else have a mouse that has a dedicated doubleclick button like A4Tech Oscar series mouse has, but that works on current F34?
I have tried running xev on Fedora and on Pop_OS, Fedora registers only one button1 (left click) event (click and release), and Pop registers two clicks and two releases (click-release-click-release) of button1 when I press the doubleclick button.

Hello, I have managed to fix this issue by adding quirks to libinput for my mouse model.


Above are the contents for my quirks file. I have submitted it upstream for approval and hopefully it will be integrated in some future update of libinput. By making this quirks file doubleclick button works as intended.