Issue with Nov 18, 2021 release - dnsmasq confict on port 53

I use core os as a docker host, there is on container running dnsmasq as LAN DNS and since release 35.20211029.3.0 it fails due to conflict on port 53. This address is now requested by systemd-resolved.

I found a temporary workaround

  • set DNSStubListener=no in /etc/systemd/resolved.conf.d/stub-listener.conf
  • force nameserver in the container resolv.conf

how can I fix this in a convenient (permanent) way


Hi, Mathieu.
I ran into this situation, and found that dnsmasq would initially fail due to that conflict, but if I were to sudo systemctl restart dnsmasq, it would start the second time and run well. I tried a number of workarounds, but achieved success by an edit to /etc/dnsmasq.conf: comment out bind-interfaces, add bind-dynamic. The next time dnsmasq starts up, it will bind to that interface dynamically.

If sudo systemctl restart dnsmasq errors out the same way, please share the results of systemctl status dnsmasq, and I’ll try to recall the other steps I took, as well as the source of my solution. By the way, if you do go to share command output, please use the </> button to keep the text from being reformatted. Thanks


Oh, and by the way, welcome to the user forum! Stick around, read the FAQs and guidelines, and perhaps you can help others resolve their issues.


You can disable systemd-resolved’s behaviour of listening on port 53 in the config.
Here’s how to do that in your butane config:

    - path: /etc/systemd/resolved.conf
      mode: 0644
      overwrite: true
        inline: |