Internet (both wifi and lan) stops working after a few minutes

I have been using Fedora silverblue since f36 (upgraded to 37). Recently, after an update, both LAN and WIFI (on the same LAN) seem to stop working after a few minutes. I can get them to work temporarily by restarting the network manager or just turning off and on the connection using gnome-applet, but it stops working again after a few minutes.

After some digging around, I tried disabling ipv6, and now it seems to work fine; however, I’m not sure if that is the best solution. I am a college student, and the LAN works fine on my room-mates laptop (Windows), so I think this might be a problem on my end instead of the college internet.

Note: it is possible that ipv6 is broken on my college internet side, and windows just switches to ipv4 by default, but I still think manual intervention should not be needed.

Here are some logs using `journalctl -u NetworkManager -b":

Jan 24 22:03:31 fedoralp NetworkManager[1191]: <info>  [1674578011.4088] manager: NetworkManager state is now CONNECTED_GLOBAL
Jan 24 22:03:32 fedoralp NetworkManager[1191]: <info>  [1674578012.5696] dhcp6 (eno1): activation: beginning transaction (timeout in 45 seconds)
Jan 24 22:03:32 fedoralp NetworkManager[1191]: <info>  [1674578012.6040] policy: set 'Wired connection 1' (eno1) as default for IPv6 routing and DNS
Jan 24 22:08:50 fedoralp NetworkManager[1191]: <info>  [1674578330.5993] manager: NetworkManager state is now CONNECTED_SITE

I am not experienced with debugging this stuff, so feel free to ask me to send any specific outputs or logs.

1 Like

You do not have to switch repeatedly. The network control panel should allow you to disable IPv6 for the interface and it always will be off.

Not all wifi APs support IPv6 and thus if your system is trying to use it a problem is seen. Turning it off is simple, as is re-enabling it if you choose.

Remember, the giant gorilla in the room is not the same as linux and has tricks not seen in the FOSS world for their own OS.

If you really want improvement in the network management in linux then I suggest you study and learn about networking then contribute to the code that supports it here.

Well, I have already disabled IPv6 for that particular connection. I will try to check out if I can fix it myself once I get time, but I just wanted to bring this up to other people’s attention who might be facing a similar problem.

Since this problem only showed up recently, I am guessing that it might be caused due to a recent (in the past 2 months) change in the kernel and or Network manager.

1 Like

Thank you for your information and hopefully it may assist others to troubleshoot similar problems.