Intel cpu limitting itself to a low frequency when under heavy load

I have an Intel core i7 1165G with a maximum frequency of 4.7 GHz but when it starts to run under heavy load, it limits itself to 2.8GHz without me asking for it. It can’t be thermal throttling because I have that one set to 75ºC (the new limit makes it unable to go above 50ºC) and it never lowered the frequency so much when I was using Fedora 37.
I will also mention that the bios of my laptop doesn’t have any option related to throttle or clock speeds so the issue can’t be related to that.

I’m using Fedora 38 Workstation with Gnome 44 (Wayland) and Linux kernel 6.2.6

Where do you have this set?

That’s not be necessary so — the firmware might not expose a setting, but still have thermal-throttling (or other) behavior which isn’t user-tunable.

I’m using intel-undervolt, my laptop’s default throttle temperature is 100ºC and I applied a 25ºC offset so it throttles at 75ºC. I have been doing this since Fedora 36 but it has never showed this kind of behavior nor it has applied this kind of limitation, so I guess the Fedora 38 update reseted or fixed some system value related to this.

Also, it can’t be an error related to intel-undervolt because uninstalling it didn’t fix the issue.

This almost sounds like it applied the offset to the previously used 75C setting and set it even lower to 50C

I also thought that, but changing the offset in the config file or even uninstalling intel-undervolt (as it is right now) don’t solve the issue either.

I have finally solved the issue by dissabling thermald.service, I still don’t know how but it was the cause of the problem but apparently it’s a bug that has been causing problems since Fedora 33

Since the olf bug report (CPU stuck at 400MHz with thermald enabled with kernel 5.8.16 · Issue #280 · intel/thermal_daemon · GitHub) has been closed it could be helpful to other users open a new bug report with recent information.