Installing a binary file in fedora

hi there,

I recently really found a terrific alternative to the main office suites but its in in the form of a binary file (tar file)

I was hoping someone could assist me on how to install this…


This is a [compressed] archive file (like .zip files). You should extract its content somewhere, and usually, inside it, there is a file to execute.
I don’t use ZohoDocs. As far as I can see the content of the archive is: two desktop files (probably this system has Ubuntu in mind? Since a .desktop file could not be placed in arbitrary places), and a .setup hidden file.
Once extracted the content (using the File application, double click on the file and the content will be extracted). Then open a terminal and go to such location and execute the setup.
In example:

cd ~/Downloads/ZohoDocs_x64/zohodocs

You may need to run chmod a+x .setup first to make it executable.

1 Like

Okay great so I just type that after I extract it, I run that command ?

Hi there

I ran the command however it didn’t seem to execute. I also opened the contents of the extracted folder and it had very little inside.

However the zipped file was a big file.

See attached below:
File zipped. :

Inside unzipped download folder is two files:

It is a big file because it contains the two visibile ones plus the hidden one. Files starting with a dot are hidden files.
If nothing happens executing .setup I don’t know. Doesn’t ZohoDocs have a support email/forum?

There is an extra backtick at the end of the line, it shouln’t be there:

cd ~/Downloads/ZohoDocs_x64/zohodocs

Good catch @ersen
(I edited my post. Sorry for the inconvenience).

1 Like

Generally, files like that aren’t executable when you first get them. If you need to run them, you have to use that command to allow them to be executed. If nothing happens when you try to run it, it may not be meant to be run, but with a name like that, it should be. How big is it, because that might give us a better idea of what’s going on.

1 Like

Hi there

Yes it ran when i corrected the typo I made.

Although I thought it was an office suite, its actually a file syncing thing. No idea how to uninstall it now.

Is there an easy way to uninstall this ?

The 2 visible files are zohodocs_installer.desktop and zohodocs_uninstaller.desktop.

The content of the uninstaller contains the command

Exec=bash -c '"$1"/.setup -UNINSTALL || "$(dirname "$2")"/.setup -UNINSTALL' dummy "%k" %k

If your install put that file on your desktop then it should be able to do the uninstall for you. If not then going to the directory where the .setup file exists you should be able to run the command

./.setup -UNINSTALL

and take care of that.


Thanks very very much !

1 Like

The typo was mine, sorry. You simply copied and pasted a command with a typo.
Two lessons:

  • don’t blindly copy and paste commands from internet :wink:
  • if you want to test software, it is better to spin up a virtual machine instead of messing your working environment :slight_smile:

Yes actually thats such a simple idea, I will do that.
Lesson Learned thanks Alessio !

1 Like

great thanks, just wondering what does the ./. signify here? backlash is for directory correct? So is ./. a code to execute a command?

./command is: execute this executable file located in the current directory.
Since in this case the file is an hidden file (files starting with a dot, in Unix are hidden files), we have:


“./” = current directory, “.setup” = the name of the file to execute, “-UNINSTALL” = option to follow when the command is executing. Or in plain english: Execute the .setup file in the current directory with “-UNINSTALL” as the option.
You can get a lot of info by a quick search for “basic bash tutorial” that can start at the beginning and help to learn all that.


thanks a lot,

is there any books you can recommend for learning BASH commands and also driving the BASH console?

I am used to MS-DOS mostly so it’s quite different for me.

great thanks a lot for explaining

BTW, note the differences in path separation characters in linux ( “/” or forward slash), vs windows (“\” or backslash). The backslash has a very different use in linux.

1 Like