Install K8S on Fedora 37 but etting [ERROR SystemVerification]: unsupported kernel release: 6.1.18-100.fc36.x86_64

I have migrated to F37 1 month back, this morining I tried to run kubeadm init (ti initialize kubernetes)

I get the following error
[ERROR SystemVerification]: unsupported kernel release: 6.1.18-100.fc36.x86_64

so why kernel is fc36? Does this mean that we cant install K8S on fedora 37?


  1. Is kernel 6.1.18 still installed?
    You can find out with dnf list installed kernel.

  2. If it is due to how recently you upgraded to F37 with few kernel upgrades since, then a simple sudo dnf remove kernel*6.1.18* would remove that kernel and all its associated files that are tripping up K8S.

Fedora by default retains a total of 3 kernel versions (plus the rescue kernel) and the one at fault may still be installed.

Thanks, I did dnf list kernel, got Installed Packages
kernel.x86_64 6.0.12-100.fc35 @updates
kernel.x86_64 6.1.18-100.fc36 @updates
kernel.x86_64 6.1.18-200.fc37 @updates
Available Packages
kernel.x86_64 6.2.9-200.fc37 updates

I ran sudo
sudo dnf remove kernel* as welol as 36

I get

No match for argument: kernel*6.0.12-100.fc35
No packages marked for removal.
Dependencies resolved.
Nothing to do.

If you really want to install K8S then you probably should upgrade the system to a current kernel with sudo dnf upgrade --refresh then reboot. After that the package should install properly.

Doing so should also automatically remove the FC35 kernel for you since that is the oldest one.
I suggested the removal with sudo dnf remove kernel*<kernel version>*. You added in some specifics that did not match the installed kernel packages which is why it did not work. The name used should have matched what was listed as installed. kernel*6.0.12-100.fc35* or kernel*6.0.12*


# dnf list installed kernel
Installed Packages
kernel.x86_64                                                    6.1.18-200.fc37                                                    @updates

# dnf remove kernel*6.1.18-200.fc37
No match for argument: kernel*6.1.18-200.fc37

# dnf remove kernel*6.1.18-200.fc37*
Dependencies resolved.
 Package                                          Architecture         Version                            Repository                   Size
 kernel                                           x86_64               6.1.18-200.fc37                    @updates                      0  
 kernel-core                                      x86_64               6.1.18-200.fc37                    @updates                     90 M
 kernel-devel                                     x86_64               6.1.18-200.fc37                    @updates                     66 M
 kernel-modules                                   x86_64               6.1.18-200.fc37                    @updates                     57 M
 kernel-modules-extra                             x86_64               6.1.18-200.fc37                    @updates                    3.2 M
Removing dependent packages:
 kmod-nvidia-6.1.18-200.fc37.x86_64               x86_64               3:525.89.02-1.fc37                 @@commandline                42 M

Transaction Summary
Remove  6 Packages

The package name must match before dnf can manage it.

So many thanks Jeff, yes this did the job and I was able to remove the fc35 kernel and refresh to latest kernel.
Have a good day