Huawei matebook 14 (2020) amd Ryzen 7 No Sound on Fedora 35

Hi, I have the Huawei matebook 14 (2020) with amd Ryzen 7, But there’s no sound on fedora 35, I try also with ubuntu 20.04 and elementary os 6 but still having the same problem.

In gnome’s settings there’s no audio output device detected. Anyway the sound works with headphones.

This is the output of inxi -Fxz :

Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Renoir Radeon High Definition Audio driver: snd_hda_intel v: kernel 
           bus-ID: 04:00.1 
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor driver: snd_rn_pci_acp3x 
           v: kernel bus-ID: 04:00.5 
           Sound Server-1: ALSA v: k5.14.11-300.fc35.x86_64 running: yes 
           Sound Server-2: PipeWire v: 0.3.38 running: yes

This is the output of aplay -l :

**** List of PLAYBACK Hardware Devices ****
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

This is the output of arecord -l :

**** List of CAPTURE Hardware Devices ****
card 0: acp [acp], device 0: DMIC capture dmic-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Any possible solutions?

I have the exact same issue, have you been able to find a solution yet Cesare?

Can you run this

systemctl --user status pipewire

sure, this is the oputput:

pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; enabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/user/pipewire.service.d
     Active: active (running) since Tue 2021-11-23 19:55:38 CET; 1min 1s ago
TriggeredBy: ● pipewire.socket
   Main PID: 4978 (pipewire)
      Tasks: 2 (limit: 18361)
     Memory: 3.4M
        CPU: 70ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─4978 /usr/bin/pipewire

Nov 23 19:55:38 fedora systemd[4960]: Started PipeWire Multimedia Service.
sudo dnf swap wireplumber pipewire-media-session 

I hope it will solve this issue.


Still no sound, nor output and input devices available in the sound settings…

1 Like

Can you check these please and thanks.

1 Like

Hey grumpey, this is actually a fresh install (first time ever trying fedora) and might not relate to the upgrade section of the wiki. However, when I run the command:

 systemctl --user status session.slice

This is the only sound related service I get:

             │ └─3619 /usr/bin/pipewire-media-session
             │ └─3621 /usr/bin/pipewire-pulse
               └─3618 /usr/bin/pipewire

systemctl --user status "wireplumber

Unit wireplumber.service could not be found.

As far as i know pipe wire has been replaced in fedora 35 with wire plumber
I think maybe wire plumber having issues starting or it haven’t installed while installing os that is the reason you are facing audio issue

systemctl --user --now disable pipewire-media-session

Then start

systemctl --user --now enable wireplumber

After doing this use pavucontrol to see your device. If it is muted, unmute.

1 Like

It might need to be re-installed.

sudo dnf swap pipewire-media-session wireplumber

You may want to have a look at,


1 Like

Thanks for taking the time everyone!

After swapping back to wireplumber from pipewire-media-session I am still not able to get any sound.

The pavucontrol however show two output devices HDMI / DisplayPort 1 (unplugged) and HDMI / DisplayPort 2 (iunplugged). I am also not able to choose any other sound options from the drops downs withing pavucontrol. In the Gnome > Settings > Sound no inoput or output options are still available for selection.

After swapping back make sure you restart it should work.

If it still does not solve this issue make verify copy of fedora 35 of your DE choice
And live boot into it check if your sound gets active in live if yes then make a fresh if not then :disappointed:

Thanks for your time as well Martin,

I have been restarting after every change I made, and the sound has not been working from a fresh install.

I am afraid the issues is related this issue posted by grumpey: 215119 – ES8336 and AMD Renoir: no sound from speakers/jack

Does this mean I have to wait for a new kernel?

Yes maybe this is true but still i will suggest please try some arch base os like garuda or endeavour and ubuntu base something just make a live boot and fedora too if that problem is still there no sound then it is evident that this is a kernel bug and give a it a post in bugzilla.
And sorry that i could not help you.

You could also try with an older kernel. (Installing an 5.10 LTS Kernel in Fedora 35 - #3 by dalto)

Bummer, I have already made a live boot of Fedora 35, Ubuntu 21.10, Ubuntu 20.10, Elementary OS 6, and some other distros (it’s all a blurr by now).

First time ever installing Fedora and I must say that I was pleasantly surprised by the system, seemed like a stable and cohesive experience that I could use to actually get some work done. Sadly this is Linux on the Desktop and there is always something that does not work for me :slight_smile:

According to your recommendations I will try some of the Arch-based distros, if thats a no-go I guess I have to head to the Apple store and pick up a new M1 :confused:

Thanks everyone for lending me your time and brainpower, I wish you an awesome day!

grumpy, would this be the best way to downgrade the kernel then?

sudo dnf copr enable kwizart/kernel-longterm-5.10
sudo dnf install kernel-longterm

Or what would be the best way, talk to me like I am 5 :smiley: