How to uninstall Proton VPN from Fedora Silverblue?

I’m trying to uninstall Proton VPN to try out IVPN since Proton frequently freezes, is laggy, and IVPN supports Silverblue and DNS over HTTPS (DoH). I used the following commands from this source to install Proton but the uninstall commands from its Fedora website don’t work on Silverblue. How do I uninstall Proton?

Proton VPN GUI install commands used:

  1. installed the ProtonVPN repo by
    rpm-ostree install

  2. Rebooted to update system directories. This makes the repo file available as

  3. ran
    sudo rpm-ostree install protonvpn

  4. to get a systray indicator
    sudo rpm-ostree install libappindicator-gtk3 gnome-tweaks gnome-shell-extension-appindicator

The folks on the Silverblue Matrix room provided me with the following two commands to uninstall Proton and it worked like a charm!

To remove the application
rpm-ostree uninstall protonvpn && sudo rm -rf /usr/lib/python3.*/site-packages/proton* && sudo rm /etc/yum.repos.d/protonvpn-stable.repo

to remove the repo
sudo rm /etc/yum.repos.d/protonvpn-stable.repo

Waited for the commands to complete, then rebooted and done.

1 Like

Isn’t /usr/ supposed to be read-only? Furthermore, isn’t removing layers from rpm-ostree supposed to bring the system back to exactly how it was before said layers? (minus config files ofc)

I don’t know very much about the ins and outs of Linux but those two commands worked flawlessly for me. Andy ( is the one who provided them, he’ll probably be down to chat with you. :slight_smile: