Home server does not access internet at certain times

Hi all,

I am setting up a home server and ran into a problem.

nmcli shows connection to home wifi enabled and active with healthy bars, but I can’t ping anything and get the error “No connection to network”.

I am inclined to believe that it is something to do with internal clocks, because the problem only happens around late morning. But I am a newbie, and could really do with help properly diagnosing and solving this issue for good.

Thank you all for your time.

So you are unable to ping an internet host. Do your router IP (the default gateway) is also unreachable?
Where do you see the “No connection error” message?

alciregi, thanks for the reply.

I’m not sure how to check if router IP is unreachable. Furthermore, everything is working smoothly right now, I don’t know why, but I also can’t fish out the error message.

If memory serves me, the “No connection to network” came any time I tried to ping my other machine from the server. Trying to use dnf didn’t work either. Apologies for the lack of precision.

Edit: also relevant is the fact that dnf was not working, in that it wasn’t even connecting with the repositories.

I am worried that this will happen again at the most inopportune moment, though. Could it be something to do with the DCHP clock?

Next time your server can’t rreach the Internet, try this:


and see how far it goes. If it doesn’t even reach the first hop, you aren’t reaching the router.

Cheers, sideburns. I just gave it a quick run to see what that looks like. I should be able to identify when things go wrong with this.

Hey sideburns, problem happened again after I rebooted the server. Did the traceroute, here’s the output

traceroute to (, 30 hops max, 60 byte packets
1 localhost.localdomain ( 3099.090 ms !H 3098.988 ms !H 3098.948 ms !H

I can’t make sense of this, but suspect it means exactly what you said: not reaching router.

So what is the problem?

I fixed it by just restarting the NetworkManager service. Not sure if the problem will persist, though.